NatalyaAlekseevich1644
?>

1. Когда прекращается цикл while? 2. Для чего нужна таблица трассировки? 3. Как с цикла while можно реализовать программу ожидания ввода чисел? 3. Самостоятельная работа Решить 2 задачи самостоятельно. Решение можно записать в тетради, либо воспользоваться средой программирования (Wing, PyCharm Задача № 1 Пользователь вводит числа одно за другим до тех пор, пока не введёт ноль. Программа должна выводить введенные числа до тех пор, пока не будет введен 0. Никаких операций с числами не производится. Формат ввода Вводятся целые числа одно за другим, на отдельных строках. Формат вывода Выводятся введенные числа на отдельных строках до тех пор, пока не будет введен ноль Пример 1 Ввод Вывод 1 2 3 4 5 6 7 8 9 0 1 1 2 3 4 5 6 7 8 9 Пример 2 Ввод Вывод 5 4 3 2 1 0 1 2 3 4 5 5 4 3 2 1 Задача № 2 В задаче № 2 нужно не только вывести числа до нуля (см. предыдущую задачу), но рассчитать и вывести их сумму: Пример 1 Ввод Вывод 5 4 3 2 1 0 1 2 3 4 5 5 4 3 2 1 15

Информатика

Ответы

Ka2ffka141
Var x1,y1,x2,y2,v1,v2:real;
begin
  writeln("введите количество метров пробегания жирафа");
  read(y1);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x1);
  writeln("введите количество метров пробегания зайца");
  read(y2);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x2);
  v1:=y1/x1;
  v2:=y2/x2;
  if v1>v2 then 
  begin
     writeln("жираф чемпион");
  end
  else if v1<v2 then 
  begin
     writeln("заяц чемпион");
  end
  else
  begin
    writeln("победила дружба);
  end;
end;
ksenia15-79
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const
  m = 10;

var
  t: array[1..m] of integer;
  i, n, nm, sm: integer;

begin
  //Заполняем массив сл.числами и подсчитываем
  //количество элементов и среднее арифметическое
  //согласно условию задачи
  for i := 1 to m do
  begin
    t[i] := random(-20, 20);write(t[i]:4);
    if (i > 1) and (i <= m) then
      if t[i] > t[i - 1] then n := n + 1
      else if t[i] < t[i - 1] then begin
        sm := sm + t[i];nm := nm + 1;
      end;
  end;
  writeln;
  writeln('число элементов больших предыдущего = ', n);
  writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);  
 
end.

Тестовое решение:
    6  13  19   8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Когда прекращается цикл while? 2. Для чего нужна таблица трассировки? 3. Как с цикла while можно реализовать программу ожидания ввода чисел? 3. Самостоятельная работа Решить 2 задачи самостоятельно. Решение можно записать в тетради, либо воспользоваться средой программирования (Wing, PyCharm Задача № 1 Пользователь вводит числа одно за другим до тех пор, пока не введёт ноль. Программа должна выводить введенные числа до тех пор, пока не будет введен 0. Никаких операций с числами не производится. Формат ввода Вводятся целые числа одно за другим, на отдельных строках. Формат вывода Выводятся введенные числа на отдельных строках до тех пор, пока не будет введен ноль Пример 1 Ввод Вывод 1 2 3 4 5 6 7 8 9 0 1 1 2 3 4 5 6 7 8 9 Пример 2 Ввод Вывод 5 4 3 2 1 0 1 2 3 4 5 5 4 3 2 1 Задача № 2 В задаче № 2 нужно не только вывести числа до нуля (см. предыдущую задачу), но рассчитать и вывести их сумму: Пример 1 Ввод Вывод 5 4 3 2 1 0 1 2 3 4 5 5 4 3 2 1 15
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ЮлияДаниил520
Yuliya701
Golovinskii_Sirotkina1944
ryadovboxing
Маринина_Елена
Matveevanastya0170
superniki87
tolyan791
movlam11
slitex
tatakypzova
ekater01806
svetasvetlana429
yulyazhdan
abroskin2002