Neveselova
?>

Напишите программу, в которой осуществляется ввод целых чисел до тех пор, пока не будет введена единица, и подсчет произведения положительных чисел, используя оператор repeat

Информатика

Ответы

mary---jane49

var a,s: integer;

begin

s:=1;

repeat

write('Введите число: ');

readln(a);

if (a>0) then s:=s*a;

until a=1;

writeln('Произведение положительных чисел: ',s);

end.

compm
                                        ДВОРНЯГА
                                       ШАРИК ТУЗИК БАРБОС
                                            БУЛЬДОГ
                                              цезарь 
                                               граф
                                                васнсар
                                                   гари   
                                                   пудель
                                                    эмма белла джозефина стелла

                                                     
moskvichkabakery56
Const
  n = 11;

var
  x: array[1..n] of integer;
  i, k, d, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    d := Random(11) - 5;
    Write(d:3);
    if (i mod 2) = 0 then begin { четное место }
      if d = 1 then Inc(k);
      x[i] := d
    end
    else begin
      if d < 0 then s := s + d;
      x[i] := sqr(d)
    end
  end;
  Writeln;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(x[i]:3);
  Writeln;
  Writeln('Количество единиц на четных местах равно ', k);
  Writeln('Сумма отрицательных элементов на нечетных местах равна ', s)
end.

Тестовое решение:
Элементы массива
 -3  0 -5  1  5  1 -3 -4  5 -3 -2
Результирующий массив
  9  0 25  1 25  1  9 -4 25 -3  4
Количество единиц на четных местах равно 2
Сумма отрицательных элементов на нечетных местах равна -13

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, в которой осуществляется ввод целых чисел до тех пор, пока не будет введена единица, и подсчет произведения положительных чисел, используя оператор repeat
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Advantage9111
tatiana2676
veravlad
Avetisyan575
boldireve617
AnastasiyaSkripin1283
alfaantonk
abahtina582
voen-torg
arbekova
snopok66
kim-1971
marinarodina90
doorhan42n6868
dokmak140652