mzia-mzia-60682
?>

Нужно написать программу на c++, которая будет рисовать полый квадрат из решеток(#) используя вложенный цикл. Вводится одна переменная: длина стороны

Информатика

Ответы

OOO"Kiprei"_Aleksandr1938

#include <iostream>

int main()

{

   int len, i, j;

   // Русский язык в консоли

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите длину стороны: ";

   std::cin >> len;

   for (i = 0; i < len; i++)

   {

       for (j = 0; j < len; j++)

       {

           if ((j == 0) || (j == len - 1) || (i == 0) || (i == len - 1)) std::cout << "#";

           else std::cout << " ";

       }

       std::cout << std::endl;

   }

   

return 0;

}

cat2572066

Математическая модель (а также программа; зависит от того, что понимать под этапом формализации).

В учебнике выделяют такие этапы решения задачи на компьютере:

Исходные данные (результат - словесная информационная модель)Формализация (математическая модель)Алгоритмизация (алгоритм)Программирование (программа)Отладка, тестирование (уточнение модели)Выполнение расчетов (получение результатов)

Нормальные люди понимают, что после формализации информация должна быть представлена на формальном языке, таких языком может быть как математический, так и язык программирования.

pavelvsk2023
Const n=8;
var x : array[1..n] of real;
   i : integer; min : real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=20*random-10;
  write(x[i]:6:2,' ');     
 end;
 writeln;
min:=x[1];
for i:=2 to n do
 if x[i] < min then min:=x[i];
writeln('min=',min:6:2);
for i:=1 to n do
 if x[i]<0 then x[i]:=min;
writeln('Измененный массив:');
for i:=1 to n do write(x[i]:6:2,' ');
end.

Пример:
Исходный массив:
 -7.84  -9.97   7.00  -8.26  -7.71  -3.88   7.59  -2.32 
min= -9.97
Измененный массив:
 -9.97  -9.97   7.00  -9.97  -9.97  -9.97   7.59  -9.97 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на c++, которая будет рисовать полый квадрат из решеток(#) используя вложенный цикл. Вводится одна переменная: длина стороны
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

extremhunter
Pilotmi247074
Татьяна1856
Elen-ti81459
omigunova39
andreanikin
ИП-Сысоев1628
egamedicalbuh
Irinalobanowa
expozition
Pervosha
serge-lysoff
Irina_Nikolai
Семеновна-Павел
ovdei71