evgeniipetrosov
?>

Напишите программу, которая вводит три числа a, b и с, если а > b, то программа находит сумму b+c. Если а=b, то программа печатает слово «Конец». Если а<с, то находит сумму a+b+c, выводит на экран эту сумму и слова «Я люблю программирование».C# ​

Информатика

Ответы

Теплова

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

Объяснение:

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

ganzashop
Var a: array of integer; var i: byte; var b: boolean; begin b: =true; setlength(a,8); var n: =0; writeln('введите число: '); readln(i); var d: =i; while i< > 0 do begin a[n]: =i mod 2; i: =i div 2; inc(n); end; setlength(a,n); for   i: =0 to n-1 do begin if n=0 then begin write(0); break; end; swap(a[i],a[n-1]); write(a[i]); end; for i: =1 to n-1 do begin if n=0 then break; if a[i-1]< > a[i] then begin b: =false; break; end; end; if (b=false) then write(' = ',d,' это не палиндром') else  write(' = ',d,' это палиндром'); end.
milaudina

еспублика беларусь – суверенное государство, полноправный член мирового сообщества. по уровню развития относится к странам с переходной малой открытой .

беларусь относится к средним по размерам территории странам мира. она занимает площадь 207,6 тыс. км, что составляет немногим более 2 % от площади европы. в мировом сообществе государств доля беларуси по площади составляет 0,15 %.

беларусь занимает компактную территорию, которая по своей форме напоминает пятиугольник. с севера на юг страна простирается на 560 км, с запада на восток – на 650 км. на автомобиле в любом направлении территорию республики можно проехать из одного конца в другой за 8-10 часов. о компактности территории свидетельствует соотношение между площадью страны и протяженностью ее границ.

конфигурацию территории страны характеризует ее глубина, это значит расстояние от государственной границы до самых удаленных пунктов. так, в швейцарии, венгрии, словакии наиболее удаленные от государственной границы пункты находятся на расстоянии около 100-120 км, в близких по площади румынии, польше – около 240-300 км. глубина территории беларуси составляет 200-220 км.

общая протяженность государственной границы республики беларусь составляет 2969 км. беларусь граничит с пятью государствами: россией, украиной, польшей, литвой, латвией.

беларусь расположена на равнинной территории, поэтому государственные границы в основном не имеют явных природных рубежей. во многих местах границы беларуси пересекаются автомобильными дорогами, железными дорогами, и .

положение страны оказывает значительное влияние на исто­рическое развитие и хозяйственную деятельность населения. оно является одним из важнейших стратегических факторов социально- развития страны.

беларусь расположена в пределах умеренного пояса. крайний северный пункт находится севернее освейского озера на широте 56°10′ с.ш. крайний южный пункт – па широте 51°16′ с.ш. недалеко от пос. комарин. с запада на восток территория беларуси простирается от 23°11' (вблизи г. высокое) до 32°47′ в.д. (недалеко от п.г.т. хотимск). согласно расчетам ученых, центр республики находится около дер. антоново пуховичского района минской области и имеет координаты 53°31' с. ш.; 28°03′ в.д. по инициативе общества там установлен памятный знак.

беларусь расположена в центре европы, которая имеет сложную фигуру. последние расчеты геодезистов доказывают, что центр европы расположен именно на территории беларуси. этот пункт находится в глубокском районе витебской области в районе оз. шо и имеет координаты 55°10′ с. ш. и 28°12′ в.д.

территория беларуси расположена во втором часовом поясе.

для беларуси характерен умеренно континентальный климат со сравнительно теплыми зимой и летом, значительной продолжительностью вегетационного периода и достаточным количеством осадков. это позволяет выращивать на территории страны все типичные для средней полосы восточной европы сельскохозяйственные культуры. таким образом, - положение беларуси в целом благоприятное для хозяйственного развития страны, освоения ее территории.

размещение беларуси в центре европы является благоприятным фактором ее - положения. нет природных преград для развития торговых отношений с большинством европейских стран. основные преимущества - положения беларуси – центральность н транзитность.

из 10 трансъевропейских транспортных коридоров два непосредственно проходят через территорию нашей страны.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит три числа a, b и с, если а > b, то программа находит сумму b+c. Если а=b, то программа печатает слово «Конец». Если а<с, то находит сумму a+b+c, выводит на экран эту сумму и слова «Я люблю программирование».C# ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

галина
vs617
purchase
razumeiko0790
edvard-b
ska67mto3983
praskovya17
petria742
stomcom01
Людмила902
mkovanov
waspmoto6188
djikia88
ВалентиновичСуриковна1104
Aнaлитикaлық мaшинaAнaлитикaлық мaшинa
tyrenumberone