Const m=5; n=3; var i,j,k:integer; a:array[1..m,1..n] of integer; begin Randomize; Writeln('Исходный массив'); k:=0; for i:=1 to m do begin for j:=1 to n do begin a[i,j]:=Random(999)+1; Write(a[i,j]:4); if (a[i,j] mod 8=0) and (a[i,j] mod 10=4) then Inc(k); end; Writeln end; if k>0 then begin Writeln('Искомые элементы'); for i:=1 to m do for j:=1 to n do if (a[i,j] mod 8=0) and (a[i,j] mod 4=10) then Write(a[i,j],' ') end else Writeln('Нет элементов, кратных 8 и оканчивающихся на 4') end.
Пример работы программы Исходный массив 424 672 826 546 587 413 507 211 884 252 781 518 750 656 359 Искомые элементы 424
vifslafes
09.12.2020
Классификация на русском языке: Части речи: (самостоятельные, служебные, междометия), звуки: (твёрдые, мягкие). Суффиксы: (действительные, страдательные) Классификация на географии: Мировой океан: (Воды суши, вода в атмосфере, вода в живых организмах), воды суши: (реки, озёры, каналы). Классификация на математике: Уравнения: (простые, сложные), числа :(двухзначные и однозначные). Классификация на биологии: Вегетативные органы растений: (корень, побег), строение цветка: (чашеложе, лепестки, пестик, тычинка)
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу на языке Паскаль, которая находит наибольший общий делитель трёх целых чисел: НОД (a, b, c (с
m=5;
n=3;
var
i,j,k:integer;
a:array[1..m,1..n] of integer;
begin
Randomize;
Writeln('Исходный массив');
k:=0;
for i:=1 to m do begin
for j:=1 to n do begin
a[i,j]:=Random(999)+1;
Write(a[i,j]:4);
if (a[i,j] mod 8=0) and (a[i,j] mod 10=4) then Inc(k);
end;
Writeln
end;
if k>0 then begin
Writeln('Искомые элементы');
for i:=1 to m do
for j:=1 to n do
if (a[i,j] mod 8=0) and (a[i,j] mod 4=10) then Write(a[i,j],' ')
end
else
Writeln('Нет элементов, кратных 8 и оканчивающихся на 4')
end.
Пример работы программы
Исходный массив
424 672 826
546 587 413
507 211 884
252 781 518
750 656 359
Искомые элементы
424