?>
1)Даны два числа А и В. Запишите логическое выражение по правилам языка Паскаль:«Число В принадлежит отрезку [-3;1]»2)Какая ошибка допущена в записи оператора. Запишите правильный ответ.IF 0<X<5 THEN X:=X + 1; ELSE X:=X*X;Составьте блок-схему, соответствующую фрагменту программы.3)Определите значение переменной «a» после выполнения фрагмента программы
Ответы
program n_1;
var a, b : string; i, s, n: integer;
begin
n:=0;
repeat
writeln('Введите слово');
readln(a);
s:=length(a);
for i:=1 to s do
begin
if a[i]='' then n:=n+1
end;
if n>=2 then b:=b+' '+a;
writeln('Слово',b);
writeln('Количество букв: ', n);
end.
program abc;
var a:string; z, i, k, l m, n: integer;
begin
k:=0;
l:=0;
m:=0;
n:=0;
writeln('Введите слово');
readln(a);
z:=length(a);
for i:=1 to z do
begin
if a[i]='Щ' then k:=k+1 else
if a[i]='Ц' then l:=l+1 else
if a[i]='Ы' then n:=n+1 else m:=m+1;
end;
writeln('Щ', k, 'Ц', l, 'Ы', n, 'О', m);
end.
это на нахождение двойных букв
program chet;
var a, l: string; s, i: integer;
begin
repeat
writeln('Введите слово');
readln(a);
s:=length(a);
for i:=1 to s do
if a[i]=a[i+1] then l:l+' '+a;
until a>' ';
writeln(l);
end.