Delyaginmikhail
?>

· Дана строка. Написать программу, выводящую на экран её длину. · Дана строка. Написать программу для вывода на экран первой и последней буквы строки. · Даны две строки. Написать программу для вывода на экран слова, полученного из суммы первых букв данных строк.​

Информатика

Ответы

sahabiev1987

ответ: Программа рабочая, проверена.

Program zadacha;

var  

 a: array [1..50] of integer; // размерность массива = 50

 i,k: integer;

begin

begin

 for i:=1 to 50 do

   a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве

 writeln('Заполненный массив: ');

 for i:=1 to 50 do

   write(a[i],' '); end; // выводим массив на экран до проверки

writeln; //новая строка

writeln('Введите значение числа K: '); readln(k);

writeln('Элементы массива, кратные K:');

for i:=1 to 50 do

if (a[i] mod k = 0) then write(a[i],' ');  

end.

Объяснение:

i - порядковый номер элемента

a - сам массив

k - вводимое число

В остальном оставила комментарии.

Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.


ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования на языке Паскаль Напишите программу для реа
ivanpetrovichru1801
Var
  h1,h2:integer;
  n1,n2:string;
begin
  Write('Введите имя первой девочки: '); Readln(n1);
  Write('Введите рост первой девочки: '); Readln(h1);
  Write('Введите имя второй девочки: '); Readln(n2);
  Write('Введите рост второй девочки: '); Readln(h2);
  if h1>h2 then Writeln(n1,' выше, чем ',n2)
  else if h2>h1 then Writeln(n2,' выше, чем ',n1)
  else Writeln(n1,' и ',n2,' одного роста')
end.

Тестовое решение:
Введите имя первой девочки: Наташа
Введите рост первой девочки: 163
Введите имя второй девочки: Даша
Введите рост второй девочки: 167
Даша выше, чем Наташа

Блок-схема дана во вложении. Блоки ввода вывода упрощены в связи с невозможностью (и ненужностью) точно отобразить вид ввода и вывода.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

· Дана строка. Написать программу, выводящую на экран её длину. · Дана строка. Написать программу для вывода на экран первой и последней буквы строки. · Даны две строки. Написать программу для вывода на экран слова, полученного из суммы первых букв данных строк.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

martinson
meu72
ilyushin-e
Marina658
m-zolotukhina2
galereyaas1568
erere4443
dzo-dzo
Maksim Lokhov
dimiff5
Gavrilova2527
ksvish2012
Olegovich Nikolaevna
ANDREY261965
Gennadevna-Darya1216