olgapotapova
?>

Информатика с тестом 1) Какое значение переменная Х будет иметь после выполнения фрагмента программы? А: = 2 В: = 3 Х:= А+2*В Варианты ответов 5 7 8 4 2) Переменная в программировании считается полностью заданной, если известны её... Тип, имя Имя, значение Тип, значение Тим, имя, значение 3) Алгоритм какого типа описан на алгоритмическом языке? Алг выбор А, В, Х Нач. Вещ Х=:А+В Х=:В-2*А Кон Варианты ответов Циклический Линейный Вс Разветвляющийся 4)Алгоритм какого типа записан на алгоритмическом языке? Алг. Выбор Нач. Вещ. А, В, Х А:=1 В:=1 Нц пока Х>5 Х:=Х+А+В кц. Кон. Варианты ответов Циклический Линейный Вс Разветвляющийся 5) Определите значение переменной b после выполнения данного алгоритма а:= -5 b:=5+7*а b:=b/2*a 6) Определите значение переменной с после выполнения данного алгоритма а:= -5 b:=3 a:=a-b*2 если a>b то c:= b-a иначе с:=a-b

Информатика

Ответы

Леонтьева

Объяснение:

Язык не был указан, так что пишу на С++:

1)

#include <iostream>

using namespace std;

int main()

{

   int buf, quantity = 0;

   cin >> buf;

   int sum = 0;

   while (buf != 0) {

       ++quantity;

       sum += buf;

       cin >> buf;

   }

   cout << "Sum: " << sum << "\nAverage: " << sum / quantity;

}

2)

#include <iostream>

using namespace std;

int main()

{

   int buf;

   cin >> buf;

   int max_num = buf;

   while (buf != 0) {

       if (max_num < buf) {

           max_num = buf;

       }

       cin >> buf;

   }

   cout << "Max: " << max_num;

}

medvik

#include - подключение библиотеки.

using namespace std; - объявление пространства имен

void swap(int x, int y, int z) - определение функции swap, которая ничего не возвращает, с принимаемыми аргументами типа int. Служит для обмена значений

{} - операторные скобки

int temp - объявление локальной переменной temp.

if(x > y ) - Если x > y, мы меняем значения x и y. temp - промежуточная переменная для хранения значения.

if(x > z) - Если x > z, мы меняем значения x и z. temp - промежуточная переменная для хранения значения.

if(y > z) - Если y > z, мы меняем значения y и z. temp - промежуточная переменная для хранения значения.

cout << x << " " << y << " " << z << "\n"; - вывод переменных x y z через пробел. \n - перевод каретки на новую строку.

}

int main() - главная функция, которая начинает свое выполнение при запуске

{

int x = 2, y = 6, z = 5; - определение переменных x y z

swap(x, y, z); - вызываем функцию и передаем ей значения x y z

system("pause >> null"); - передача команды "pause >> null" командному процессору. Тормозим выполнение программы. >> null означает, что не будет ничего написано. (Без этого будет писать, в роде: Для продолжения нажмите")

return 0; - возвращаемое значение

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика с тестом 1) Какое значение переменная Х будет иметь после выполнения фрагмента программы? А: = 2 В: = 3 Х:= А+2*В Варианты ответов 5 7 8 4 2) Переменная в программировании считается полностью заданной, если известны её... Тип, имя Имя, значение Тип, значение Тим, имя, значение 3) Алгоритм какого типа описан на алгоритмическом языке? Алг выбор А, В, Х Нач. Вещ Х=:А+В Х=:В-2*А Кон Варианты ответов Циклический Линейный Вс Разветвляющийся 4)Алгоритм какого типа записан на алгоритмическом языке? Алг. Выбор Нач. Вещ. А, В, Х А:=1 В:=1 Нц пока Х>5 Х:=Х+А+В кц. Кон. Варианты ответов Циклический Линейный Вс Разветвляющийся 5) Определите значение переменной b после выполнения данного алгоритма а:= -5 b:=5+7*а b:=b/2*a 6) Определите значение переменной с после выполнения данного алгоритма а:= -5 b:=3 a:=a-b*2 если a>b то c:= b-a иначе с:=a-b
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tselyaritskaya Yurevich
kuzinnv1968
Dr-motoshop
kryshtall2276
serge-lysoff
svetsalikowa
Igorevich_Aleksandrovna1599
rykovatv6
skorpion7228528
Анатольевич-Митюшин
Valentinovna
ldfenix87
Геннадьевич-Тимофеева158
alicia179
stasletter
▲