var a: array [1..100] of integer; i,n,min,max: integer; begin read(n); for i : = 1 to n do read(a[i]); min: =a[1]; max: =a[1]; for i: = 1 to n do begin write(a[i],' '); if max< a[i] then max: =a[i]; if min> a[i] then min: =a[i]; end; writeln(min,max); end.
Поделитесь своими знаниями, ответьте на вопрос:
Pascal abc написать программу вычесления стоимости покупки состоящей из нескольких тетрадей и карандашей
begin //начало программы
var nk, nt, ck ,ct, s: integer // переменных типа действительные числа;
writeln('введите количество карандашей'); //вывести на экран надпись
readln(nk); // запись ответа пользователя в переменную nk
writeln('введите количество тетрадей'); //вывод на экран надписи
readln(nt); // запись ответа пользователя
writeln('введите стоимость 1 карандаша'); // вывод на экран надписи
readln(ck); // запись ответа пользователя в переменную
writeln('введите стоимость 1 тетради');
readln(ct);
s: =(nk*ck)+(nt*ct); // вычисление стоимости покупки
writeln('стоимость покупки: ',s); // вывод стоимости покупки на экран
end. // конец программы
(ck-стоимость 1 карандаша, ct-стоимость 1 тетради, s-стоимость покупки)
(nk-количество карандашей, nt-количество тетрадей)