girra
?>

Известны координаты вершин A, B, C треугольника (xa, ya, xb, yb, xc, yc Напишите программу на Phyton, вычисляющую площадь этого треугольника.

Информатика

Ответы

Serafim

ответ: 13

Объяснение:

задача на оценку + пример

оценка:

для каждого человека можно выбрать 2-ух - которых нельзя вставить в дружеское жюри вместе с ним (может быть, что 1 это только 1 человек). => если для каждого 2 этих человека - разные мы можем взять ровно 1/3 от всех людей = 13. => ответ >= 13

пример (что 13 - макс).

возьмем 3 -х людей. 1 критикует 2-го, 2-ой 3-го, 3-ий первого. И разобьем 39 ученых на 13 таких троек, получим, что из каждой тройки можем взять только 1 ученого =>макс ученых 13

но данное количество учёных в жюри может быть верным, только в данной последовательности

festjob

program znanija;

begin

 var x := readinteger();

 var y := readinteger();

 var z := readinteger();

 writeln('Сумма = ', x + y + z);

 writeln('Произведение = ', x * y * z);

 writeln('Сумма квадратов = ', sqr(x) + sqr(y) + sqr(z));

 writeln('Среднее арифметическое = ', (x + y + z) / 3);

end.

Объяснение:

Функция sqr() возводит число в квадрат.

Среднее арифметическое = сумма чисел ÷ количество чисел

program znanija;  // Название программы

begin  // Начало программы

 var x := readinteger();  // Объявление переменной x и считывание целочисленного числа с клавиатуры

 var y := readinteger();  // Объявление переменной y и считывание целочисленного числа с клавиатуры

 var z := readinteger();  // Объявление переменной z и считывание целочисленного числа с клавиатуры

 writeln('Сумма = ', x + y + z);  // Вывод суммы

 writeln('Произведение = ', x * y * z);  // Вывод произведения

 writeln('Сумма квадратов = ', sqr(x) + sqr(y) + sqr(z));  // Вывод суммы квадратов

 writeln('Среднее арифметическое = ', (x + y + z) / 3);  // Вывод среднего арифметического

end. // Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Известны координаты вершин A, B, C треугольника (xa, ya, xb, yb, xc, yc Напишите программу на Phyton, вычисляющую площадь этого треугольника.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gorod7
Екатерина
kuliba
Avshirokova51
dvpered
rublevaoe392
yuliyastatsenko3894
Aleksandrovna-Marina
lor005148
Mikhailovna1444
madjk
igor-790
Letajushaya362
Anna572
nataliarogacheva