moto-eskort
?>

Составить программу по блок схеме начало ввод a a больше 0 ? да a=a+1 нет вывод a конец

Информатика

Ответы

svetlana-ladyga

Решение программы прилагаю на снимке экрана.

===С++===


Составить программу по блок схеме начало ввод a a больше 0 ? да a=a+1 нет вывод a конец
kokukhin

2) Вопрос не понял, но думаю правильно ответил:

var a,b,c,d :int64;

begin

readln(a);

b := a -1;//число до  

c := a +1;//число след.

writeln('Число до: ',b,' Число след.: ',c);

end.

3)

var a,b,c,d :int64;

begin

readln(a);//Кол-во учеников

readln(b);//Кол-во яблок

c := b div a;//Яблок каждому ученику

d := b - (a * c);//Яблок в корзине  

writeln('Яблок каждому: ',c,' Яблок осталось в корзине: ',d);

end.

4)

var a,b,c,d:int64;

begin

readln(a);//Число

b := a mod 10;//остаток от деления

c := a div 10;//деление без остатка

d := c mod 10;//остаток от деления

writeln('При последнее число: ',d,' Последнее число: ',b);

end.

5)

var a,b,c,d:int64;

begin

readln(a);//Автобус за день  

readln(b);//Кол-во дней

c := a * b;

writeln('Автобус проехал: ',c,' (км)');

end.

6)

var a,b,c,d:int64;

begin

readln(a);//Путь муравья

b:= a div 1000;//м

c:= (a - (b*1000)) div 10;

//см

d:= a - (b*1000+c*10);

//мм

writeln('Путь муравья: ',b, ' (м) ',c,' (см) ',d,' (мм)');

end.

7)

var a,b,c,d:int64;

begin

readln(a);//Грань куба

b := a*a*a ;

writeln('Объем куба: ',b, ' м^3');

end.

8)

var a,b,c,d,g:real;

begin

readln(a,c,d,b);//Числа

g:=(a+c+d+b) / 4 ;

writeln('Cреднее арифметическое: ', g);

end.

9)

var a,b,c,d:real;

begin

readln(a,b,c);//Учеников в кадом классе

d:= (a+b+c)/ 2;

writeln('Кол-во парт для 3 классов: ', d);

end.

Объяснение:Все программы написаны на Pascal.

Капец много задач за 5б)))

voropayelena26
Математические  дроби - то есть это : ⅟ ½ ⅓ ¼ ⅕ ⅙ ⅐ ⅛ ⅑ ⅒ ⅔ ¾ ⅖ ⅗ ⅘ ⅚ ⅜ ⅝ ⅞.
Знаки тире как: длинное тире , цифровое тире , горизонтальная линия .
Математические символы такие как: ∫ ∬ ∭ ∮ ∯ ∰ ∱ ∲ ∳
∃ ∄ ∅ ∆ ∇ ∈ ∉ ∊ ∋ ∌ ∍ ∎ ∏ ∐ ∑ − ∓ ∔ ∕ ∖ ∗ ∘ ∙ √ ∛ ∜ ∝ ∟ ∠ ∡ ∢ ∣ ∤ ∥ ∦ ∧ ∨ ∩ ∪ ∴ ∵ ∶ ∷ ∸ ∹ ∺ ∻ ∼ ∽ ∾ ∿ ≀ ≁ ≂ ≃ ≄ ≅ ≆ ≇ ≈ ≉ ≊ ≋ ≌ ≍ ≎ ≏ ≐ ≑ ≒ ≓ ≔ ≕ ≖ ≗ ≘ ≙ ≚ ≛ ≜ ≝ ≞ ≟ ≠ ≡ ≢ ≣ ≤ ≥ ≦ ≧ ≨ ≩ ≪ ≫ ≬ ≭ ≮ ≯ ≰ ≱ ≲ ≳ ≴ ≵ ≶ ≷ ≸ ≹ ≺ ≻ ≼ ≽ ≾ ≿ ⊀ ⊁ ⊂ ⊃ ⊄ ⊅ ⊆ ⊇ ⊈ ⊉ ⊊ ⊋ ⊌ ⊍ ⊎ ⊏ ⊐ ⊑ ⊒ ⊓ ⊔ ⊕ ⊖ ⊗ ⊘ ⊙ ⊚ ⊛ ⊜ ⊝ ⊞ ⊟ ⊠ ⊡ ⊢ ⊣ ⊤ ⊥ ⊦ ⊧ ⊨ ⊩ ⊪ ⊫ ⊬ ⊭ ⊮ ⊯ ⊰ ⊱ ⊲ ⊳ ⊴ ⊵ ⊶ ⊷ ⊸ ⊹ ⊺ ⊻ ⊼ ⊽ ⊾ ⊿ ⋀ ⋁ ⋂ ⋃ ⋄ ⋅ ⋆ ⋇ ⋈ ⋉ ⋊ ⋋ ⋌ ⋍ ⋎ ⋏ ⋐ ⋑ ⋒ ⋓ ⋔ ⋕ ⋖ ⋗ ⋘ ⋙ ⋚ ⋛ ⋜ ⋝ ⋞ ⋟ ⋠ ⋡ ⋢ ⋣ ⋤ ⋥ ⋦ ⋧ ⋨ ⋩ ⋪ ⋫ ⋬ ⋭ ⋮ ⋯ ⋰ ⋱ ⋲ ⋳ ⋴ ⋵ ⋶ ⋷ ⋸ ⋹ ⋺ ⋻ ⋼ ⋽ ⋾ ⋿ ✕ ✖ ✚.
Символы как процент -‰
Римские цифры : Ⅰ Ⅱ Ⅲ Ⅳ Ⅴ Ⅵ Ⅶ Ⅷ Ⅸ Ⅹ Ⅺ Ⅻ
ⅰ ⅱ ⅲ ⅳ ⅴ ⅵ ⅶ ⅷ ⅸ ⅹ ⅺ ⅻ.
Цифры в кружках - ⓵ ⓶ ⓷ ⓸ ⓹ ⓺ ⓻ ⓼ ⓽ ⓾ ➊ ➋ ➌ ➍ ➎ ➏ ➐ ➑ ➒ ➓
⓪ ➀ ➁ ➂ ➃ ➄ ➅ ➆ ➇ ➈ ➉ ⑪ ⑫ ⑬ ⑭ ⑮ ⑯ ⑰ ⑱ ⑲ ⑳
❶ ❷ ❸ ❹ ❺ ❻ ❼ ❽ ❾ ❿ ⓫ ⓬ ⓭ ⓮ ⓯ ⓰ ⓱ ⓲ ⓳ ⓴
Латинские буквы в кружочках:
ⒶⒷⒸⒹⒺⒻⒼⒽⒾⒿⓀⓁⓂⓃⓄⓅⓆⓇⓈⓉⓊⓋⓌⓍⓎⓏ
ⓐⓑⓒⓓⓔⓕⓖⓗⓘⓙⓚⓛⓜⓝⓞⓟⓠⓡⓢⓣⓤⓥⓦⓧⓨⓩ
Знаки валютных купюр : $ € ¥ £ ƒ ₣ ¢ ¤ ฿ ₠ ₡ ₢ ₤
Смайлики:㋛ ソ ッ ヅ ツ ゾ シ ジ ッ ツ シ ン 〴 ت ☺ ☻ ☹
Рука , указательнйы палец и многое другое ( ✉ ✍ ✎ ✏ ✐ ✑ ✒,☚☛☜☝☞☟✌,✆ ☎ ☏,

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу по блок схеме начало ввод a a больше 0 ? да a=a+1 нет вывод a конец
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

poiskmarina
dmitrijku
andreu420082132
kareeva
soclive7762
Д.О. Игорь
Диана-Николаевна377
potapenkoon72
Некрасов Валентина1097
alakhverdov138
Павловна897
ВасильевнаСергей
Tuzov
sunrise
burtsev3339