Lenamihluk50
?>

Даны две матрицы А(nxn) и C(nxn Написать программу вычисления матрицы Ст*(А+С), где Ст - транспонированная матрица. Необходимо написать на C++

Информатика

Ответы

lazarevaavrora

А(nxn) и C(nxn):Ст*(А+С)

Объяснение:

volodinnikolay19

cd ~

mkdir folder1

cd folder1

touch file1

touch file2

touch file3

touch file4

tar cvf archive.tar *

mkdir ../folder2

cd ../folder2

touch new_file

cp ../folder1/archive.tar .

tar rvf archive.tar new_file

tar vf archive.tar --delete file3

tar vf archive.tar --list > list1

tar vf ../folder1/archive.tar --list > list2

diff list1 list2

#Разъединение выполнить не получится, потому что все файлы пустые, но если засовывать не пустые, то

split -b 10M archive.tar "part" # вместо 10M нужный размер

cat part* > joined_archive.tar

tar vf archive.tar --list

tar vf joined_archive.tar --list

tar czvf final_archive.tar archive.tar ../folder1/archive.tar joined_archive.tar

glebshramko
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var a:=MatrixRandom(7,7,0,9);
  var k:=0;
  for var i:=0 to 6 do begin
    for var j:=0 to 6 do begin
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Тестовое решение:
  2  1  7  3  3  2  7
  9  2  9  2  0  5  5
  4  2  6  9  4  6  0
  1  0  3  5  4  5  9
  6  3  6  0  2  0  8
  0  8  4  3  2  1  8
  6  0  4  4  5  4  0
Кол-во элементов на [1,5]: 27

Вариант "совсем для школы"

const
  n=7;
var
  a:array[1..n,1..n] of integer;
  i,j,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(10);
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны две матрицы А(nxn) и C(nxn Написать программу вычисления матрицы Ст*(А+С), где Ст - транспонированная матрица. Необходимо написать на C++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hobpack
Коваленко
terehin863
tonyakuznetsova
vps1050
demon8608
pechinin
Anastasiya Yevseeva948
SaraevaTretyakov1941
Вишняков997
sokolowskayaa
alexeytikhonov
keshka12719
okykovtun31
Федоровна-Васильева