Задача:Напишите программу вычисления наибольшего общего делителя двух целых чисел.А) используйте оператор while.Б) используйте оператор НУЖНО СКИНУТЬ ДО 12:00
cout << "Введите число, из которого нужно удалить цифру: ";
cin >> num;
while (true)
{
cin.clear();
cin.ignore(1024, '\n');
cout << endl << "Введите цифру, которую нужно удалить из числа: ";
cin >> A;
if (A < 0 || A > 9)
{
cout << "Ошибка! (Нужно ввести цифру (0..9), а не число)";
continue;
}
break;
}
int newNum{}, counter{ 1 };
while (num > 0)
{
if (num % 10 != A)
{
newNum += counter * (num % 10);
counter *= 10;
}
num /= 10;
}
cout << endl << "Введённое число без цифры " << A << ": " << newNum;
return 0;
}
ASRodichev
21.04.2023
Class MiddleTemperature{ public static void main(String args[]){ java.util.Scanner in = new java.util.Scanner(System.in); double tSum = 0; for(int day = 0; day<7; day++){ switch(day){ case 0: System.out.print("Понедельник>>"); break; case 1: System.out.print("Вторник>>"); break; case 2: System.out.print("Среда>>"); break; case 3: System.out.print("Четверг>>"); break; case 4: System.out.print("Пятница>>"); break; case 5: System.out.print("Суббота>>"); break; case 6: System.out.print("Воскресенье>>"); break; } tSum+=in.nextInt(); } tSum/=7; System.out.print("Средняя температура за неделю: "+(int)tSum/1+"."+(int)(tSum%1.0/0.1)+(int)((tSum-(int)(tSum/0.1)/10D)/0.01)); } }
#include <iostream>
using namespace std;
int main()
{
setlocale(0, "");
int num{}, A{};
cout << "Введите число, из которого нужно удалить цифру: ";
cin >> num;
while (true)
{
cin.clear();
cin.ignore(1024, '\n');
cout << endl << "Введите цифру, которую нужно удалить из числа: ";
cin >> A;
if (A < 0 || A > 9)
{
cout << "Ошибка! (Нужно ввести цифру (0..9), а не число)";
continue;
}
break;
}
int newNum{}, counter{ 1 };
while (num > 0)
{
if (num % 10 != A)
{
newNum += counter * (num % 10);
counter *= 10;
}
num /= 10;
}
cout << endl << "Введённое число без цифры " << A << ": " << newNum;
return 0;
}