milkline-nn
?>

На Phyton1) Написать программу, которая считывает строки с клавиатуры до тех пор, пока не будет введена строка, начинающаяся на "*"2) Написать программу, которая позволяет считать строку с клавиатуры и вычисляет количество символов "а" в ней. Гарантируется, что хотя бы один такой символ в ней содержится.

Информатика

Ответы

bellatrixstudio

1

string = input()

while string[0] != '*':

   string = input()

2

print(input().count('а'))

Узлиян Фурсов1488

1 байт = 8 бит

1Кб = 1024 байт

Странное задание. Логики не поддается

1)Перевести в килобайты:

•  1024 байт = 1 Кб

• 210 байт = 210 / 1024 = 0,205 Кб

• 213 байт = 213/1024 = 0,208 Кб

• 216 байт = 216/1024 = 0,211 Кб

• 213 бит = 213/8 = 26,625 байт / 1024 = 0,026 Кб

• 216 бит = 216/8 = 27 байт / 1024 = 0,0264 Кб

• 0,25 байт = 0,25/1024 = 0,000244 Кб


2) Расположить величины в порядке возрастания

10 бит, 2 байта, 20 бит, 1010 байт, 1 Кбайт


Задача на повторение темы “Круги Эйлера”

Музык состоит из частей представленных на рисунке - 1,4,5,7

Худ - 2,5,7,6

Спорт - 3,4,7,6

Известно что всего  24 учеников

музыкальную школу посещают 10 человек, значит части 1+4+5+7 = 10

художественную школу - 8  человек, части 2+5+7+6 = 8

спортивную школу - 12 человек, 3+4+7+6 = 12

музыкальную и художественную школу- 3,  части 5+7 = 3

художественную и спортивную школу - 2, части 7+6 = 2

музыкальную и спортивную школу - 2, части 4+7 = 2

все три школы   посещает 1 человек.  часть 7 = 1

т.к. часть 7 = 1, то часть 4 = 1 (2-1), часть 6 = 1 часть 5 = 2

из этого следует (в скобках количество детей)

музыкальную школу посещают 10 человек, значит части 1+4 (1)+5 (2)+7 (1) = 10 значит часть 1 = 10-1-2-1 = 6

художественную школу - 8  человек, части 2+5 (2)+7(1)+6(1) = 8 значит часть 2 = 8-2-1-1=4

спортивную школу - 12 человек, 3+4(1)+7(1)+6(1) = 12 , значит часть 3 = 12-1-1-1 = 9

Всего занято детей = части 1+2+3+4+5+6+7 = 6+4+9+1+2+1+1 = 24

Сколько учеников посещают только одну школу?

Только по одной школе посещают (части 1+2+3) = 6+4+9 = 19 чел

Сколько учащихся ни в чем себя не   развивают?  Все заняты

Обязательно нарисовать круги, в каждой области указать количество человек.



Тема “измерение информации” в каждом подробно писать расчеты. 1)перевести в килобайты:  1024 байт 
stachevay-lera

4 единицы

Объяснение:

1 байт = 8 бит = 8 разрядов для числа

22 / 2 = 11 + остаток 0

11 / 2 = 5 + остаток 1

5 / 2 = 2 + остаток 1

2 / 2 = 1 + остаток 0

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

22 в 10 СС = 10110 в 2 СС

Для получения внутреннего представления целого числа достаточно перевести число в двоичную систему счисления и дополнить полученный результат слева нулями до нужной разрядности.

При представлении со знаком самый старший (левый) разряд отводится под знак числа, остальные разряды - под само число. Если число положительное, то в знаковый разряд помещается 0 , если число отрицательное - 1.

-22 -> 10010110

4 единицы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На Phyton1) Написать программу, которая считывает строки с клавиатуры до тех пор, пока не будет введена строка, начинающаяся на "*"2) Написать программу, которая позволяет считать строку с клавиатуры и вычисляет количество символов "а" в ней. Гарантируется, что хотя бы один такой символ в ней содержится.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ev89036973460
Yurevna-Anatolevna
manager-3
Daletskaya Sergei1121
Soliyabronzoni
spikahome
Alenachernika9111
Васильевичь Виктория457
Vkois56
suhanowaswetlana
VSArsentev
MArat
ВладимировнаИП37
purbuevat56524
Petrosienko_Larisa,1908