simplexsol
?>

Напишите программу которая выводит случайное число в диапазоне от a до b.После этого вводится еще одно вещественное число. Выведите отдельно целую часть и дробную часть произведения случайного целого числа на введенное вещественное

Информатика

Ответы

alex091177443

var a, b: real; i: integer;

begin  

randomize;  

readln(a,b);  

for i:= 1 to 5 do    

write((Random()*(b-a)+a):0:3, ' ');

end.

klimovala2

1) 2304 КБайт

2) 5625 КБайт, видеокарта на 64 МБайт

3) 112,5 МБайт

Объяснение:

Задача 1:

16 777 216 = 2^i,   i = 24

I = 1024 * 768 * 24 = 2^10 * 3 * 2^8 * 24 битов =

= 72 * 2^18 битов  = 72 * 2^15 байтов = 72 * 2^5 Кбайт = 72*32 КБайт =

= 2304 КБайт

Задача 2:

16 777 216 = 2^i,   i = 24

I = 1600 * 1200 * 24 = 100 * 2^4 * 75 * 2^4 * 24 битов =

= 25 * 2^2 * 2^4 * 75 * 2^4 * 3 * 2^3 битов = 25*75*3* 2^13 битов  = 5625* 2^10 байтов = 5625* 2^0 Кбайт = 5625 КБайт ≈ 5,5 МБ

Подойдет видеокарта на 64 Мбайт.

Задача 3:

75 Гц, значит в одной секунде 75 кадров.

Объем данных, передаваемых в секунду от видеопамяти к монитору:

75 * 16 * 1024 * 768 = 75 * 2^4 * 2^10 * 3 * 2^8 = 225 * 2^22 битов =

= 225 * 2^19 байт = 225 * 2^9 КБайт = 112,5 * 2^10 КБайт = 112,5 * 2^0 МБайт = 112,5 МБайт

Николаевич
 Всегда задавалась вопросом чем же язык программирования отличается от систем программирования. Наверное всё же система программирования это средство, которое позволяет писать программы, на определенном языке программирования, или на нескольких определенных языках, азык программирования: это система обозначений, которая позволяет записывать алгоритмы.
Чтоб алгоритм работал на машине, нужно: описание, на языке программирования, ввести в систему программирования, которая по этому описанию сделает выполняемую программу. Кроме транслятора, система программирования содержит весь набор инструментов для работы: текстовые редакторы, конструкторы, отладчики, и тд. Поэтому называется "система"

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая выводит случайное число в диапазоне от a до b.После этого вводится еще одно вещественное число. Выведите отдельно целую часть и дробную часть произведения случайного целого числа на введенное вещественное
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Janaz842060
Александрович Владимирович
Какой году был втарой война​
terma-msk1
Buninilya
gulyaizmailova
vnolenev
nordwokintos4
aidapiltoyan43
Larisa-Andrei
artmasterstyle
АндреевичОльга641
elenaftdv7
ilukianienko458
vrn3314
mpityk
▲