Елена-Олег
?>

Задача 3. Напишите программу, которая получает с клавиатуры число роз (целоечисло, не превышающее 100) и выводит это число со словом «роза», «роз» или«розы». Например, «31 роза», «5 роз», «24 розы». С и надо. ​

Информатика

Ответы

baron

Код проверен, и работает корректно! Если вас не устраивает слово 'Роз', просто поменяйте его на любое другое.

program gjvhj;

var

bool: boolean;

a: integer;

begin

readln(a);

bool := true;

begin

if a < 100 then

writeln(a, ' Роз', ';') end ;

begin

if a > 100 then

writeln('Введите число, меньше 100! ') ;

end;

end.

zmlavra
Описание состава и структуры реквизитов документа. (формат документа- общее определение).

Текстовые форматы

.txt – первый формат для текстовых файлов, в котором не используется форматирование (размер шрифта, полужирный, отступ абзаца и пр,). Содержит только текст.

.doc – формат, который использовался долгое время в текстовом редакторе Word компанииMicrosoft. Наиболее распространенный для текстовых редакторов.

.docx – формат для текстового редактора Word компании Microsoft, который появился в пакете Microsoft office 07 (2007 год) и имеется в Office 10. Не все редакторы поддерживают данный формат, так как эта лицензионная разработка компании Microsoft.  

.odt – формат для текстового редактора Write пакета свободный офис (OpenOffice). 

.rtf – формат для текстового редактора, имеющий возможность использоваться в разных операционных системах, то есть, можно переносить с компьютера, имеющего одну операционную систему на другой компьютер с другой операционной системой.

.pdf – формат для текстового файла, разработанных компанией Adobe. Имеется меньшие размеры и лучше передает рисунки по сравнению с другими форматами. Когда он был разработан, то редактор для создания подобных файлов нужно было купить у компании Adobe. В то же время для любого пользователя можно было скачать просмотровщик данного файла. Многие компании делали текстовую информацию именно в этом формате, поэтому он стал популярен.

.chm – формат файла, который используется для хранения нескольких файлов формата html. Создан для замены формата справочной системы. Может иметь ссылки, по которым возможен переход на другую страницу.

Андреевнатест707
Program n1;
const maxm = 50;     
         maxn = 50;
var a:array[1..maxm,1..maxn] of integer;   
      min,max,i,j,n,m,x,maxi,mini:integer;
begin
write('Введите размеры матрицы (N*M): ');
readln(n,m);
writeln('Введите матрицу из ',n,' строк и ',m,' столбцов:');
min:=maxint; max:=-maxint-1;
for i:=1 to n do 
 for j:=1 to m do   
  begin   
   read(a[i,j]);
   if a[i,j]>max then begin max:=a[i,j]; maxi:=i; end;
   if a[i,j]<min then begin min:=a[i,j]; mini:=i; end;   
  end;

for j:=1 to m do 
begin 
 x:=a[maxi,j]; a[maxi,j]:=a[mini,j]; a[mini,j]:=x; 
end;

writeln('Матрица после преобразования:');
for i:=1 to n do 
begin 
 for j:=1 to m do 
  write(a[i,j],' '); 
 writeln; 
end;

end. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача 3. Напишите программу, которая получает с клавиатуры число роз (целоечисло, не превышающее 100) и выводит это число со словом «роза», «роз» или«розы». Например, «31 роза», «5 роз», «24 розы». С и надо. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alenchik19938823
rusvicktor
servik78
oyudina
Некрасов Валентина1097
a-lossev111
severbykova
char40
fudan
Baidina
Anastasiya
av4738046
Kati2005
Verakravez8790
Девяткина_Арсений