Khlustikova_Borisovna
?>

Напишите программу с процедурой, которая считает среднее арифметическое среднесуточных температур месяца и количество дней когда температура была выше 100, но ниже 320. Значения среднесуточных температур вводятся с клавиатуры, всего 30 значений.

Информатика

Ответы

di-bobkov1985
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
ayk111560
Интернет по сути своей не представляет опасности для подрастающего поколения. Вредоносное влияние оказывают многочисленные сайты и всплывающие окна рекламного характера. Помимо образовательной роли виртуальная реальность таит и множество негативных моментов, в особенности для детей. Это может быть:

незаконный контент: «взрослая» реклама табака, алкоголя, секса, азартные игры, порнография;платные сервисы и услуги, которые оплачиваются отдельно;призывы к асоциальному поведению, насилию и жестокости;пропаганда сексуальной эксплуатации и суицидального поведения;общение на форумах и чатах с мошенниками, аферистами и преступниками под личиной доброжелателей;вынуждение предоставления личной информации ребенка или его семьи, которая может быть использована в преступных целях;Интернет-зависимость.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу с процедурой, которая считает среднее арифметическое среднесуточных температур месяца и количество дней когда температура была выше 100, но ниже 320. Значения среднесуточных температур вводятся с клавиатуры, всего 30 значений.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stperelyot7833
praskovya17
kolyabelousow4059
Less2014
horizma609
skorpion7228528
karien87
ruslan
komarov-dmitriy
utburt
diana0720
Vyacheslavovna
spodobnyi
gutauta6
ivanpetrovichru1801
▲