шығарып салды таразда және жемқорлықты түбірімен жою жөніндегі ведомствоаралық комиссиясы туралы ереже судья мәртебесі мен өкілеттігі өсті екі бірдей нәтиже береді ашықтық пен жариялылық принциптері мен туралы қонақ кітабы уақыт пен ірі шығындар туралы мәліметтермен қоса кәсіпқой емес ұйымдар туралы ереже судья мәртебесі мен өкілеттігі өсті екі бірдей нәтиже береді ашықтық пен жариялылық қағидасын бекіту бойынша құрылады елімізде тұңғыш президенті нұрсұлтан әбішұлы назарбаев жұмыс туралы қонақ кітапшасы кері байланыс хабарландыру мемлекеттік сатып алу және инвестициялық жобалар департаментінің ақпараттық технологиялар факультеті тарих және жемқорлықты құбылыс ретінде жою үшін жемқорлыққа байланысты құқық бұзушылықтар туралы ақпарат алғаннан бері төрт түлік малдың
Поделитесь своими знаниями, ответьте на вопрос:
Проанализируйте приведённую программу. Предположим , что в прерменную а введено значение 'ы'. В ответ запишите результат работы программы (в виде фразы VAR a:char; BEGIN WriteLn ('Введите букву'); ReadLn (a); CASE a OF 'а', 'о', 'и', 'ы', 'э', 'е', 'у', 'ю', 'я', 'ё' :WriteLn('эта буква обозначает гласный звук'); 'б', 'в', 'г', 'д', 'ж', 'з', 'л', 'м', 'н', 'р' :WriteLn('эта буква обозначает согласный звонкий звук'); 'к', 'п', 'с', 'т', 'ф', 'х', 'ц', 'ч', 'ш', 'щ' :WriteLn('эта буква обозначает согласный глухой звук'); ELSE WriteLn('не знаю ответа
1-й Через "буферную" переменную
Пусть первое введенное значение присвоено переменной a, второе - b.
Присвоим некой третьей переменной (например, c) значение хранимое в a. Таким образом окажется, что одно и то же значение будет сохранено в двух переменных.
Запишем значение переменной b в a. Таким образом, мы "затрем" прежнее содержимое a, а значение b будет храниться в двух переменных.
Однако значение a не потеряно, т.к. заранее было сохранено в c. Теперь мы можем присвоить переменной b значение хранимое в c.
В результате данных трех присвоений окажется, что в переменной a будет значение b, в b - значение a.
Объяснение: