bolosolo77
?>

РЕБЯТКИ ПРЯМ СУПЕР Определите значение переменной после выполнения следующего фрагмента программы: i := 3; while i < 203 do i := i + 4;​

Информатика

Ответы

kmr495270

203

Объяснение:

он будет выполнять команду пока условие соблюдены

через 50 кругов i станет 203 и не будет отвечать условию

Alexander2035
Program zadacha;varA: array[1..8] of integer;i,kolvo_pol,proiz_otr: integer;beginfor i:=1 to 8 do read(A[i]);kolvo_pol:=0;proiz_otr:=1;
for i:=1 to 8 do beginif A[i]>0 then kolvo_pol:=kolvo_pol+1;end;writeln();writeln('kolvo_pol = ', kolvo_pol);
for i:=1 to 8 do beginif A[i]<0 then proiz_otr:=proiz_otr*A[i];end;writeln('proiz_otr= ', proiz_otr);end.

program zadacha;varC: array[1..10] of integer;i: integer;beginfor i:=1 to 10 do read(C[i]);writeln();
for i:=1 to 10 do beginif C[i]>0 then C[i]:=sqr(C[i]);end;
for i:=1 to 10 do beginif C[i]<0 then C[i]:=20;end;
for i:=1 to 10 do write(C[i]:6);end.
orb-barmanager
1. Современное решение

// PascalABC.NET 3.2, сборка 1367 от 20.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var c:=ReadArrInteger('Введите элементы массива: ',10);
  c.Transform(x->x>0?x*x:x=0?x:20); c.Println
end.

Пример
Введите элементы массива:  5 11 -7 0 3 -12 -8 1 9 -2
25 121 20 0 9 20 20 1 81 20

2. Традиционное "школьное" решение

const
  n=10;
var
  i:integer;
  c:array[1..n] of integer;
begin
  Write('Введите элементы массива: ');
  for i:=1 to n do Read(c[i]);
  for i:=1 to n do
    if c[i]>0 then c[i]:=sqr(c[i])
    else
      if c[i]<0 then c[i]:=20;
  for i:=1 to n do Write(c[i],' ');
  Writeln
end.

3. Улучшенное "школьное" решение

const
  n=10;
var
  i,t:integer;
  c:array[1..n] of integer;
begin
  Write('Введите элементы массива: ');
  for i:=1 to n do begin
    Read(t);
    if t>0 then c[i]:=t*t
    else
      if t<0 then c[i]:=20
    end;
  for i:=1 to n do Write(c[i],' ');
  Writeln
end.

Решите на 4 или на 5 9 класс,массивы на 4 дан массив а(8) ввод данных с клавиатуры.найти произведени
Решите на 4 или на 5 9 класс,массивы на 4 дан массив а(8) ввод данных с клавиатуры.найти произведени

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕБЯТКИ ПРЯМ СУПЕР Определите значение переменной после выполнения следующего фрагмента программы: i := 3; while i < 203 do i := i + 4;​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Качкова1820
Dmitrii1763
amarantmetall
kmb1960679
okykovtun31
Марина566
iptsr4968
axo4937
ВладимировичМорозова1941
kosbart28
nastikak8
snip99
rayman777
Сергеевна-Иван1045
lakeeva90