balabinatanya7174
?>

Напишите программу Для числового отрезка АВ определяет, сколько среди целых, натуральных чисел, принадлежащих отрезку [АВ] четных и при этом больших чем Z.. Выводит на экран количество таких чисел.

Информатика

Ответы

ludmila-malev280

import random

def GenEx(count):

   signs = ['+', '-', '*', '/']

   for _ in range(count):

       fn = random.randint(-20, 20)

       sn = random.randint(-20, 20)

       ex = '{0} {1} {2}'.format(fn, random.choice(signs), sn)

       yield (ex + ' = ?', eval(ex))

IsGameRun = True

while IsGameRun:

   TrueAnsws = 0

   for ex, check in GenEx(2):

       print(ex)

       resvAnsw = float(input())

       if resvAnsw == check: TrueAnsws += 1;

   

   IsRetry = input('You correctly solved '+str(TrueAnsws)+' examples. Do you want to try again? Y/N \n')

   if IsRetry == 'Y': IsGameRun = True

   else: IsGameRun = False

Объяснение:

gorovoy-dv4088

ответить

+0-

TfuTfu

29 сент. 2015 г., 21:19:36 (2 года назад)

таких нет - все, что может быть сделано имеет какое-то отношение к информации.

Пример:

ты передвинул кружку. Соответственно изменилось расстояние от кружки до края стола, а расстояние храниться в виде информации. Просто эта информация нуждается в считывании.  

Другой пример: ты чихнул. Казалось бы, что может иметь чих общего с изменением информации? На самом деле связь можно найти всегда. Тут можно говорить о количестве микробов в воздухе, о влажности, о чем угодно)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу Для числового отрезка АВ определяет, сколько среди целых, натуральных чисел, принадлежащих отрезку [АВ] четных и при этом больших чем Z.. Выводит на экран количество таких чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info-mosbalkon
snabomp
КалюкМарасанов1026
mon84
ntinyakova
Latsukirina
Larisa-Andrei
pavlino-mkr
MAXIM76748
Щуплова Александр
lbeglarova6
nataliaterekhovasinger2
devochkadafka624
Alekseevich1012
Orestov563