Исакова-Александрович511
?>

На паскале. 4. Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 во Победителем викторины считается участник, правильно ответивший на наибольшее количество во На сколько во победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из во выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из во Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество во на которые получен правильный ответ

Информатика

Ответы

Карапетян

var N, i, a, m:integer;

c:boolean;

begin

 writeln('Введите количество участников');

 readln(N);

 if ((N < 1) or (N >50))then begin

   writeln('Ошибка');

   exit;

 end;

 m := 0;

 c := false;

 for i:=1 to N do begin

   writeln('На сколько вопросов правильно ответил ',i,' участник:');

   readln(a);

   if ((a < 0) or (a > 20)) then begin

     writeln('Ошибка');

     exit;

   end;

   

   if (a = 0) then

     c := true;

   

   if (a > m) then

     m:= a;

 end;

 writeln('Количество вопросов, на которые ответил победитель правильно: ', m);

 if (c = false) then

   writeln('Есть ли участники, которые не ответили ни на один вопрос правильно: NO')

 else write('Есть ли участники, которые не ответили ни на один вопрос правильно: YES');

 

end.

dashafox8739
Var
  a,r:real;
begin
  Write('Введите a и n: '); Read(a,r);
  if a=2*r then Writeln('Квадрат описан около окружности')
  else Writeln('Квадрат не описан около окружности')
end.



var
  n:char;
  cm:string;
begin
  Write('Введите натуральное двухзначное число: '); Readln(cm);
  Write('Введите цифру от 0 до 9: '); Readln(n);
  if pos('3',cm)>0 then Writeln('В числе есть цифра 3')
  else Writeln('В числе нет цифры 3');
  if (pos('6',cm)>0) or (pos('7',cm)>0) or (pos('9',cm)>0)
    then Writeln('В числе есть цифра 6,7 или 9')
    else Writeln('В числе нет цифры 6,7 или 9');
  if pos(n,cm)>0 then Writeln('В числе есть цифра ',n)
  else Writeln('В числе нет цифры ',n)
end.
kalina1372
Const nx =50;
var z:array[1..nx] of integer; i,j,n,m,d,s,s1,k:integer; sr:real;
begin
write ('Введите число элементов n');read(n);
for i:= 1 to n do begin
z[i]:= random(30)-5;
write(z[i]:3);
if z[i]=0 then m:=i;end;writeln;
if m > 0 then begin
for j:=1 to n do begin
if (j< m) and (z[j] mod 2 = 0) then  s:= s + z[j];
if (j> m) and (z[j] mod 2 = 1) then begin s1:= s1 + z[j]; k:= k +1; end;end;end
else
begin
writeln;
for i:=1 to n do begin
for j:=2 to n do begin
if z[j] > z[j-1] then begind:=z[j-1]; z[j-1]:=z[j];  z[j]:= d;end;end;
end;end;writeln;
sr:= s1 /k;
if m > 0 then begin
writeln('сумму нечетных чисел от последнего нулевого значения до Z[N]', s:6);
write('среднее арифметическое четных чисел, находящихся в массиве до последнего нуля ', sr:6:3);
end
else
for j:=1 to n do
write(z[j]:3);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На паскале. 4. Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 во Победителем викторины считается участник, правильно ответивший на наибольшее количество во На сколько во победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из во выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из во Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество во на которые получен правильный ответ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

skalegin68
ulyana-d
Пимкина Сергеевич
alina-bas
Vladimirovich58
heodbxbbshe
Georgievich-Zamudinovna2003
Avdeeva Inga1505
okasnab
buyamel
Viktoriya405
yatania-popovich7
Mark-Petrovich
zelreiki
valerii-borisovich550