IAleksandrovna45
?>

Python Ученик принес K конфет в класс. Он хочет раздать все конфеты поровну между N одноклассников, но конфет может не достаться всем в равном количестве. Некоторым ученикам достанется на 1 конфету меньше. Напишите программу, которая вычислит скольким ученикам достанется на 1 конфету меньше.

Информатика

Ответы

Хрулёва

ответ: K - N mod K

===

dashafox8739
Без конкретики структуры множеств представим множества векторными.

Множеству "A" будет отвечать массив _a, а множеству "B" массив _b

#include <iostream>
void main()
{
    int _a[7];
    int _b[7];
   /*
      сюда нужно добавить алгоритм заполнения значениями множества
      будь то программное или пользовательское!
   /*
   int read = 0; //переменная для пользовательского числа
   unsigned int caret = 0; // переменная играющая роль каретки для массивов
   std::cin >> read; //читаем
   while(_a[caret]) // пока элемент массив _a[caret] существует
   {
        if (_a[caret++] == read) //сравниваем пользовательское значение со значением в массиве и двигаем каретку вперед
        {
             std::cout << "значение принадлежит множеству 'A' " << std::endl;
        } 
   }
   caret = 0; //обнуляем каретку
   while(_b[caret]) //все тоже только с массивом _b
   {
        if (_b[caret++] == read)
        {
             std::cout << "значение принадлежит и(или) множеству 'B' " << std::endl;
        } 
   }
}

Удачи c:
frsergeysavenok
Тут такой принцип. Есть таблица, в которой каждой шестнадцатеричной цифре соответствует двоичный код: 
16 система 2 система 
0= 0000 
1= 0001 
2= 0010 
3 =0011 
4 =0100 
5= 0101 
6= 0110 
7 =0111 
8 =1000 
9= 1001 
А =1010 
B =1011 
C =1100 
D =1101 
E =1110 
F= 1111 
С этой таблицы записываем наше шестнадцатеричное число, переводя каждую цифру в двоичный код: 
1011 0010 1011 0001 0110 
Чтобы перевести число в четверичную систему, этот код разбиваем на группы по две цифры, и каждую группу переводим в четверичную цифру, так как в четверичной системе каждая цифра кодируется двумя двоичными цифрами: 
Двоичная система Четверичная система 
00= 0 
01=1 
10 =2 
11= 3 
Получаем 
10 11 00 10 10 11 00 01 01 10 = 2302230112

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python Ученик принес K конфет в класс. Он хочет раздать все конфеты поровну между N одноклассников, но конфет может не достаться всем в равном количестве. Некоторым ученикам достанется на 1 конфету меньше. Напишите программу, которая вычислит скольким ученикам достанется на 1 конфету меньше.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Яковчук1911
Палкина-Дроздова
Vladimirovna1370
ovdei71
andreanikin
Pilotmi247074
Lapushkina
Смирнов-Оськина
Татьяна1856
Маринина_Елена
rkorneev19061
Sergei_Olga658
kriapex
Голосова-Лобанов1555
annino