Кононова-БЕСКРОВНАЯ
?>

У Ержана есть плитка шоколада. Размер плитки шоколада N x M. Ержан хочет, сделав только один разлом (по вертикали или горизонтали), получить K кусочков шоколада. Напишите программу, которая Ержану определить может ли он получить K кусочков. Вводные данные: в трех строках даны 3 числа, первое N, второе M и третье число K. Выходные данные: сообщение "Yes", если можно поделить и сообщение "No", если не возможно​

Информатика

Ответы

Vladimirovich Aleksandr1889
Реализация на с++

Уровень А
#include<iostream.h>

using namespace std;

int main(){
  int a,b;
  cin >>a >> b;
  double s = 0.5 * a * b;
  cout << s << endl;
  return 0;
}
Уровень B
#include<iostream.h>

using namespace std;

int main(){
  int n;
  cin >> n;
  (n%3==0) ? n*2 : n+n%3;
  cout << n << endl;
  return 0;
}
Уровень C
#include<iostream.h>

using namespace std;

int main(){
  int summa = 0;
  for(int i = 1; i < 100; i+=2){
     summa += i;
  }
  cout << summa << endl;
  return 0;
}
vet30
var
  x, y, z: integer;
begin
  writeln('-1 - конец ввода и вывод суммы');
  repeat
    readln(y);
    
    if (y < -1) then 
      writeln('Эм... Не, не съем: отрицательная цЫфра.')
    else
      if (y >= 0) then 
        z := z + y
      else
        if (y = -1) then
          if (z >= 100) then
            break
          else
            writeln('Не, не годится, прибавь ещё чуток, до сотни не дотягивает');
 
    if (z > 1000) then
    begin
      writeln('Всё, перевес. Сумма чисел больше 1000.');
      exit;
    end;
    
    until (false);
  writeln('Сумма примерно равна (если округлить) ', round(z / 10) * 10);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

У Ержана есть плитка шоколада. Размер плитки шоколада N x M. Ержан хочет, сделав только один разлом (по вертикали или горизонтали), получить K кусочков шоколада. Напишите программу, которая Ержану определить может ли он получить K кусочков. Вводные данные: в трех строках даны 3 числа, первое N, второе M и третье число K. Выходные данные: сообщение "Yes", если можно поделить и сообщение "No", если не возможно​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Бурмистрова-Ирина660
ЭдуардовнаКлючников1361
milkiev
Лоскутова
chumakanna17
Хабарьева Андрей1056
pechatlogo4
iptsr4968
Каныбек698
alapay
Nadezhda
vovkiv7864
koldunovan
istok11
galustyanvitaly4842