jstepanova
?>

Найти и исправить ошибки в программе. program sochet; var n, k : integer; a1, a2, a3, c : lohgint; Function factorial(n:integer):longint; var i: integer; rez : longint; begin rez:=1; for i:=1 to n do rez:=rez*i; factorial:=rez; end; begin writeln(‘ ввод n и k :’); readln(n, k); a1:=factorial(n); { вычисление n!} a2:=factorial(k); { вычисление k!} a3:=factorial(n-k); {вычисление (n-k)!} c:=a1 div (a2*a3); { результат} writeln(‘результат=’, c) ; end.​

Информатика

Ответы

Попова1271
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
Taniagrachev

1. Подключаются библиотеки, задаётся пространство имён standart, объявляется main, устанавливается поддержка русского языка, объявляется дробная переменная "temp", в консоль выводится "Введите произвольное число: ", запрашивается значение переменной temp, выполняется проверка на равенство значения 36.6. Если оно равно, то выводится в консоль "У вас нормальная температура тела", иначе "У вас повышенная температура", возвращается код ошибки ноль.

2. Ошибки:

Отсутствуют фигурные скобки в функции main (т. е. { })

Логическая ошибка: температура в случае, если она не равна 36.6 может быть не повышенной, а пониженной.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найти и исправить ошибки в программе. program sochet; var n, k : integer; a1, a2, a3, c : lohgint; Function factorial(n:integer):longint; var i: integer; rez : longint; begin rez:=1; for i:=1 to n do rez:=rez*i; factorial:=rez; end; begin writeln(‘ ввод n и k :’); readln(n, k); a1:=factorial(n); { вычисление n!} a2:=factorial(k); { вычисление k!} a3:=factorial(n-k); {вычисление (n-k)!} c:=a1 div (a2*a3); { результат} writeln(‘результат=’, c) ; end.​
Ваше имя (никнейм)*
Email*
Комментарий*
▲