D.Yu. Polina1703
?>

РЕШИТЬ НА PYTHON 1. Введите с клавиатуры значения элементов массива, увеличьте каждый элемент в 2 раза и выведите полученный массив на экран. 2. Введите с клавиатуры значения элементов массива и увеличьте на 5 значения всех элементов массива, кроме первого и последнего. 3. В массиве чётное число элементов. Введите с клавиатуры значения элементов массива, и выполните две операции: а) увеличьте на единицу значения всех элементов в первой половине массива; б) увеличьте в 2 раза значения всех элементов во второй половине массива. 4. Введите с клавиатуры значения элементов массива и найдите их среднее арифметическое. 5.Напишите программу, которая заполняет массив случайными числами на отрезке [–2; 2] и считает сумму положительных элементов массива. 6.Напишите программу, которая заполняет массив случайными числами на отрезке [2; 10] и считает отдельно количество чётных и нечётных элементов. 7.Напишите программу, которая заполняет массив случайными числами на отрезке [1000; 2000] и считает количество элементов, в десятичной записи которых вторая с конца цифра (число десятков) – чётная.

Информатика

Ответы

vikapar2646

Aaaf

Объяснение:

Sofinskaya1185

Объяснение:

1.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

for thing in a:

   new_array.append(int(thing) * 2)

print(new_array)

2.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

last_elem = int(a.pop())

counter = 0

for thing in a:

   if counter == 0:

       new_array.append(int(thing))

       counter += 1

   else:

       new_array.append(int(thing) * 5)

new_array.append(last_elem)

print(new_array)

3.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

part = int(len(a) / 2)

new_array = []

for thing in a[:part]:

   new_array.append(int(thing) + 1)

for thing in a[part:]:

   new_array.append(int(thing) * 2)

print(new_array)

4.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

print(sum([int(number) for number in a]) / len(a))

5.

import random

numbers = range(-2, 3)

random_array = random.sample(numbers, random.randint(1, 4))

positive = [numb for numb in random_array if int(numb) > 0]

print(sum(positive))

6.

import random

numberss = range(2, 11)

numbers = random.sample(numberss, random.randint(1, 9))

d = {"Чётные": 0, "Нечётные": 0}

for thing in numbers:

   if int(thing) % 2 == 0:

       d["Чётные"] += 1

   else:

       d["Нечётные"] += 1

print(f"Масив: {numbers}")

print(", ".join([f"{v}: {d[v]}" for v in d]))

7. Не сильно понял задачу, можно объяснить по-подробнее?)

a96849926288

1) Количество записей = 3

2) Количество записей = 4

3) Количество записей = 1

4) Количество записей = 2

Объяснение:

Фамилия || Пол || Математика || Русский язык || Физика || Информатика

Авдеев      || м || 80 || 72 || 68 || 66

Березин    || м || 75 || 88 || 69 || 61

Васильева || ж || 85 || 77 || 73 || 79

Додон        || м || 77 || 85 || 81 || 81

Егорова     || ж || 88 || 75 || 79 || 85

Зорина       || ж || 72 || 80 || 66 || 70

1) (Математика > 75) И (Информатика > 75)

Между выражениями стоит И - оба выражения должны быть истинными, чтобы всё выражение было истинным.

Фамилия || Пол || Математика || Русский язык || Физика || Информатика

Васильева || ж || 85 || 77 || 73 || 79

Додон        || м || 77 || 85 || 81 || 81

Егорова     || ж || 88 || 75 || 79 || 85

Количество записей = 3

2) (Математика > 75) ИЛИ (Информатика > 75)

Между выражениями стоит ИЛИ - хотя бы одно выражение должно быть истинным, чтобы всё выражение было истинным.

Фамилия || Пол || Математика || Русский язык || Физика || Информатика

Авдеев      || м || 80 || 72 || 68 || 66

Васильева || ж || 85 || 77 || 73 || 79

Додон        || м || 77 || 85 || 81 || 81

Егорова     || ж || 88 || 75 || 79 || 85

Количество записей = 4

3) Не (Пол = "ж") И (Физика > 70)

⇒ (Пол = "м") И (Физика > 70) - применил НЕ

Между выражениями стоит И - оба выражения должны быть истинными, чтобы всё выражение было истинным.

Фамилия || Пол || Математика || Русский язык || Физика || Информатика

Додон || м || 77 || 85 || 81 || 81

Количество записей = 1

4) (Математика > 75) И (Информатика > 75) И (Русский язык > 75)

Между выражениями стоит И - оба выражения должны быть истинными, чтобы всё выражение было истинным.

Фамилия || Пол || Математика || Русский язык || Физика || Информатика

Васильева || ж || 85 || 77 || 73 || 79

Додон        || м || 77 || 85 || 81 || 81

Количество записей = 2

nzagrebin363

1.Архивация :запись информации в электронном виде для долговременного хранения. 2.Архивирование позволяет сократить в несколько раз время передачи файлов по Интернету, а также поместить на дискету, компакт-диск или другой носитель значительно большее количество данных. 3.Архивный файл - это специальным образом организованный файл, содержащий в себе один или несколько файлов в сжатом или несжатом виде и служебную информацию об именах файлов, дате и времени их создания или модификации, размерах. 4.РАЗАРХИВАЦИЯ — компьютерный термин, означающий процесс, обратный архивации, т. е. процесс восстановления записи сжатых, архивных файлов или их копий для использования в работе. 5.Для каждого содержащегося в архиве файла в оглавлении хранится следующая информация об этом файле: имя файла;сведения о каталоге, в котором находился файл,дата и время последней модификации файла;размер исходного файла и сжатого файла в архиве,код циклического контроля (он позволяет проверить целостность архива). 6.Функции и характеристики Простейшие архиваторы просто последовательно объединяют (упаковывают) содержимое файлов в архив, который, помимо файловых данных, содержит информацию об именах и размерах исходных файлов, чтобы можно было точно восстанавливать файлы в их первозданном виде. Пользуйся

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШИТЬ НА PYTHON 1. Введите с клавиатуры значения элементов массива, увеличьте каждый элемент в 2 раза и выведите полученный массив на экран. 2. Введите с клавиатуры значения элементов массива и увеличьте на 5 значения всех элементов массива, кроме первого и последнего. 3. В массиве чётное число элементов. Введите с клавиатуры значения элементов массива, и выполните две операции: а) увеличьте на единицу значения всех элементов в первой половине массива; б) увеличьте в 2 раза значения всех элементов во второй половине массива. 4. Введите с клавиатуры значения элементов массива и найдите их среднее арифметическое. 5.Напишите программу, которая заполняет массив случайными числами на отрезке [–2; 2] и считает сумму положительных элементов массива. 6.Напишите программу, которая заполняет массив случайными числами на отрезке [2; 10] и считает отдельно количество чётных и нечётных элементов. 7.Напишите программу, которая заполняет массив случайными числами на отрезке [1000; 2000] и считает количество элементов, в десятичной записи которых вторая с конца цифра (число десятков) – чётная.
Ваше имя (никнейм)*
Email*
Комментарий*