steam22-9940
?>

Написать программу, которая создает текстовый файл, содержащий информацию о N книгах. Каждая книга имеет автора, название, год издания. Примерное содержание файла: Толстой Л.Н. Война и мир 2010 Дж. Толкин Властилин колец 2015

Информатика

Ответы

yok887062
Алгоритм решения

Для начала давай посмотрим на года.

1. Если разница между годом рождения и текущим годом больше 16, мы однозначно можем сказать, что человеку уже есть 16.

2. Если разница между годом рождения и текущим годом меньше 16, мы однозначно можем сказать, что человеку ещё нет 16.

Если разница между годом рождения и текущим годом равна 16, мы можем сказать, что у человека день рождения в этом году. Давай глянем на месяц.

1. Если текущий месяц больше месяца рождения, человеку уже есть 16.

2. Если текущий месяц меньше месяца рождения, человеку ещё нет 16.

Если у человека день рождения в этом месяце, давай точно так же глянем на дни.

В итоге мы уже точно знаем, когда у человека день рождения.


Код решения

#include <bits/stdc++.h>

using namespace std;


int main() {

   int d1, m1, y1, d2, m2, y2;

   cin >> d1 >> m1 >> y1 >> d2 >> m2 >> y2;

   if (y2 - y1 > 16) {

       cout << "YES" << endl;

       return 0;

   } else if (y2 - y1 < 16) {

       cout << "NO" << endl;

       return 0;

   }

   if (m2 > m1) {

       cout << "YES" << endl;

       return 0;

   } else if (m2 < m1) {

       cout << "NO" << endl;

       return 0;

   }

   if (d2 < d1) {

       cout << "NO" << endl;

       return 0;

   }

   cout << "YES" << endl;

   return 0;

}


Файл решения прикреплён.

ganorussia
) В числе не меньше двух цифр, которые меньше шести.
Следовательно, в числе две цифры в диапазоне от 0 до 5, а третья может быть и больше.
2) В числе не меньше двух четных цифр.
Следовательно, в числе одно цифра может быть и нечетной.
3) Если число должно быть наибольшим, то его старшая цифра должна быть не меньше остальных. Учитывая 1) и 2) выбираем в качестве старшей цифры девятку. Тогда две оставшиеся меньше шести и обе четные.
4) С учетом того, что число должно быть наибольшим, выберем цифры четыре.

ответ: 944

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая создает текстовый файл, содержащий информацию о N книгах. Каждая книга имеет автора, название, год издания. Примерное содержание файла: Толстой Л.Н. Война и мир 2010 Дж. Толкин Властилин колец 2015
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

prostopo4ta29
anytkaakk
perfectorg
nanasergevn
Владимир1524
anastasiaevent4
yulyashka2142
petrowanastya202081
Olesya
rina394992
Dmitriy2211104
sharovaeln6
тахирович_Игорь581
Andei
peshnoshamon