ivanovk3599
?>

Вычислите среднее арифметическое и среднее геометрическое двух чисел. (Напишите программу в тетради или в Pascal ABC)

Информатика

Ответы

Vladimirovna

45

Объяснение:

потому что полчаса решал

Gera8061
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
Овсянкина407
В общем случае, трассировка - один из отладки программ врукопашную: состояние программы контролируется на определённом отрезке времени её выполнения путём анализа значений переменных. трассировка в том или ином виде при отладке программ сложнее школьного дз практически неизбежна.
в простейшем случае, трассировка - вывод значений переменных на экран (например, в окно консоли) , либо расчёт их на бумажке для каждого шага.
в более продвинутом варианте используются точки останова, окно наблюдения, выполнение по шагам и, если есть, контекстный интерпретатор выражений.
есть также специальная "трассирующая консоль" - интерфейс вывода информации из программы в отладчик, если таковой присутствует.
почти любой современный отладчик показывает состояние програмm при её останове, что делает трассировку процессом легко доступным

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вычислите среднее арифметическое и среднее геометрическое двух чисел. (Напишите программу в тетради или в Pascal ABC)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kia80
germanleon
olartamonov6
troian07
НатальяРуктешель472
alexandergulyamov
ekaterinasamoylova4705
luza5
juli19657
shpakohat
Galkin Vladimirovich729
ikalabuhova
ivanovk3599
voen-torg
kgrechin