Yevgenevich775
?>

PYTHON: В игре «Русское лото» из мешка случайнымобразом выбираются бочонки, на каждом из которыхнаписано число от 1 до 90. Напишите программу, которая выводит наугад первые 5 выигрышныхномеров.«B»: Доработайте программу «Русское лото» так, чтобы все 5 значений гарантированно были быразными (используйте разные диапазоны

Информатика

Ответы

Seropyan-Elena1944
Var 
  m1,m2,m5,m10,m50,m100,m500,s:integer;
begin 
m1:=0;
m2:=0; 
m5:=0; 
m10:=0; 
m50:=0; 
m100:=0; 
m500:=0; 
readln(s); 
while s>0 do 
begin   
if s>=500 then   
begin     
s:=s-500;     
m500:=m500+1;   
end   
else     
if s>=100 then     
begin       
s:=s-100;       
m100:=m100+1;     
end     
else       
if s>=50 then       
begin         
m50:=m50+1;         
s:=s-50;       
end       
else         
if s>=10 then         
begin           
s:=s-10;           
m10:=m10+1;         
end         
else           
if s>=5 then           
begin             
m5:=m5+1;             
s:=s-5;           
end           
else             
if s>=2 then             
begin               
m2:=m2+1;               
s:=s-2;             
end             
else             
begin               
m1:=m1+1;               
s:=s-1;             
end; 
end; 
writeln('500р = ',m500); 
writeln('100р = ',m100); 
writeln('50р = ',m50); 
writeln('10р = ',m10); 
writeln('5р = ',m5); 
writeln('2р = ',m2); 
writeln('1р = ',m1);
end.
YelenaZOLTANOVICh105
Из Истории -
1)  Наполеон Бонапарт - французский государственный деятель.
2) Христофор Колумб - открыл новый свет.
Из Географии -
1) Россия - самое большое государство по площади.
2) В Китае больше всего населения.
Из биологии -
1) Растения производят кислород.
2) У коровы есть вымя.
Из математики -
1) 2+2=4
2) 6-2=4
Из Русского языка -
1) В русском алфавите - 32 буквы.
2) В сложном предложении 2 грамматические основы.
Из Литературы -
1) А.С. Пушкин - русский поэт.
2) "Войну и Мир" Написал Л.Н. Толстой.
Из информатики -
1) Информатика - наука о работе с информацией.
2) Вирт Никлаус - специалист в области информатки.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTHON: В игре «Русское лото» из мешка случайнымобразом выбираются бочонки, на каждом из которыхнаписано число от 1 до 90. Напишите программу, которая выводит наугад первые 5 выигрышныхномеров.«B»: Доработайте программу «Русское лото» так, чтобы все 5 значений гарантированно были быразными (используйте разные диапазоны
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Karpova
baranovaas
M19026789436
svt5299
Терентьева
Yarovitsin
Юлия-Ольга1313
mashumi2170
Светлана
abrolchik8511
fashbymsk
AndrukhovichKonovalov
zinasekina4
sbalashov62
grekova5