badalovao256
?>

Написать программу в C# и составить блок-схему: Дано трехзначное число. Найти сумму и произведение его цифр. Ввести трехзначное число А = … Цифра сотен равна …. Цифра десяток равна …. Цифра единиц равна …. Сумма цифр равно … Произведение цифр равно …

Информатика

Ответы

rnimsk149
В качестве примера равномерного кода можно назвать ASCII-таблицу, где каждому из 256 символов сопоставлено двоичное значение от 00000000 до 11111111. Независимо от вероятности появления символа на его представление отводится 1 байт, или 8 бит. Как известно, национальные языки обладают большой избыточностью, то есть разницей между энтропией источника и максимально возможной энтропией, обусловленной равной вероятностью появления любого символа из алфавита. Например, избыточность русского языка составляет 70%, а английского – 50%. Это в частности означает, что некоторые буквы появляются в тексте гораздо чаще других и поэтому использовать равномерное кодирование нерационально.
При неравномерном кодировании часто встречающимся символам сопоставляются более короткие кодовые последовательности, редко встречающимся – более длинные. За счет этого удается значительно сократить объем файла без потерь информации. Существует несколько методов неравномерного кодирования, важнейших из которых является метод Шеннона-Фано.
как-то так 
dearmaria

/*суммы будем сравнивать по модулю, в ином случае программа не будет иметь смысла, так как сумма отрицательных всегда будет меньше, чем сумма положительных*/

#include <iostream>

#include <cmath>

using namespace std;

void check() {

float s_positive = 0, s_negative = 0, digit;

try {

 cout << "Начинайте ввод чисел" << endl;

 do {

  cin >> digit;

  if (digit > 0)

   s_positive += digit;

  else

   s_negative += digit;

 } while (digit != 0);

 if (s_positive > abs(s_negative))

  cout << "Сумма положительных чисел больше!";

 else if (abs(s_negative) > s_positive)

  cout << "Сумма отрицательных чисел больше!";

 else

  cout << "Суммы равны по модулю!";

}

catch (...) {

 cout << "Ошибка!";

}

}

signed main() {

setlocale(LC_ALL, "Rus");

check();

return 0;

}


С++, Ввести с клавиатуры положительные и отрицательные числа, пока не будет введен 0. Определить, чт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в C# и составить блок-схему: Дано трехзначное число. Найти сумму и произведение его цифр. Ввести трехзначное число А = … Цифра сотен равна …. Цифра десяток равна …. Цифра единиц равна …. Сумма цифр равно … Произведение цифр равно …
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Elvira-Natalya
kabanovae
molodoychek
Valerevna-Vardan
proh-dorohova5244
Петренко1852
asi19776
fygasika
kuliba
sergeevna
ВасилийМалюга152
abrolchik8511
Viktorovich
sve34166163
semenovakotya577