Привет, я тестировал на VS 2017, но разницы нет, я тебя уверяю (по крайней мере в данном случае).
Кратко об моём решении. Запускаю цикл и считываю символ в переменную, если это точка, добавляю к счётчику +1, если доллар - цикл прекращается.
Мой вариант решения:#include <iostream>
using namespace std;
int main()
{
char symbol;
int counter = 0;
do
{
cout << "Enter symbol -> ";
cin >> symbol;
if (symbol == '.') counter++;
} while (symbol != '$');
cout << "Dot's counter " << counter << endl;
cin.get();
cin.get();
}
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу в Бейсик , определяющую, что за символы скрываются под кодами 33, 66, 99, 100, 128.
Будем рассматривать каждую итерацию.
Создаём 2 переменные, x со значением 13 и y со значением 2.
Условие y < 12 ? т.е. 2 < 12 ?
Да!
Переходим к следующему условию, y <= x ?
Да!
От x отнимаем 3 и y умножаем на 2.
Итог: x = 10, y = 4
Возвращаемся к условию y < 12 ?
Да!
y <= x ?
Да!
От x отнимаем 3 и y умножаем на 2.
Итог: x = 7, y = 8
Возвращаемся к условию y < 12 ?
Да!
y <= x ?
Нет!
От y отнимаем 3, умножаем x на y
Итог: y = 5, x = 35
Возвращаемся к условию y < 12 ?
Да!
y <= x ?
Да!
От x отнимаем 3 и y умножаем на 2.
Итог: x = 32, y = 10
Возвращаемся к условию y < 12 ?
Да!
y <= x ?
Да!
От x отнимаем 3 и y умножаем на 2.
Итог: x = 29, y = 20
Возвращаемся к условию y < 12 ?
Нет!
Конец алгоритма.
Конечные значения переменных: x = 29, y = 20.