aquilonis
?>

Для русскоязычных: басы-начало, соңы-конец, иә-да, жоқ-нет Нужно написать программу в С++

Информатика

Ответы

Aleksandrovna Kolesnik1764

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

Karpova

В бутылке, стакане, кувшине и банке находится молоко, лимонад, квас и вода. Известно что вода и молоко не в бутылке, а сосуд с лимонадом находится между кувшином и сосудом с квасом, в банке - не лимонад и не вода. Стакан находится около банки и сосуда с молоком. Как распределены эти жидкости по сосудам?

Решение

Бутылка - НЕ вода, НЕ молоко (т.к. вода и молоко не в бутылке

Стакан - НЕ молоко (т.к. Стакан находится около сосуда с молоком)

Кувшин -НЕ лимонад, НЕ квас (т.к. а сосуд с лимонадом находится между кувшином и сосудом с квасом)

Банка - НЕ лимонад, НЕ вода, НЕ молоко (т.к. в банке - не лимонад и не вода., ...около банки и сосуда с молоком), остается, что в банке - квас

т.к. в бутылке и стакане НЕ молоко, значит молоко в кувшине

т.к. в бутылке НЕ вода, значит вода в стакане

значит остается, что в бутылке - лимонад

в банке - квас

молоко в кувшине

вода в стакане

в бутылке - лимонад

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Для русскоязычных: басы-начало, соңы-конец, иә-да, жоқ-нет Нужно написать программу в С++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zverevahelen
kortikov77
ekaterinaorl1998
борисовна Елена78
alexk13
AverinAA6077
printlublino
spikahome
uuks2012
Маргарита595
oksanashabanovadc3197
abahtina582
Stefanidi_Semeikina1896
Надежда-Андрей930
rikki07834591