yatania-popovich7
?>

Ребят , сколько сможете Задание 1 Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл. Задание 2 Напишите программу, которая находит минимальное четное среди отрицательных и максимальное нечетное среди положительных чисел, записанных в файле, и выводит результат в виде написанных в столбик чисел в другой файл. Учтите, что таких чисел может вообще не быть.

Информатика

Ответы

Михайлович1309

1

var

mas:array[1..100] of integer;

i,n:integer;

en,out:text;

res:real;

qw,qwe:string;  

begin

 n:=0;

 i:=1;

 write('Введите полный путь к импортируемому файлу: ');readln(qw);

 write('Введите полный путь к экспортируемому файлу: ');readln(qwe);

 assign(en,qw+'.txt'); assign(out,qwe+'.txt');  

 reset(en); rewrite(out);

 while not Eof(en) do    

 begin

 readln(en,mas[i]);      

 n:=n+mas[i];                

 inc(i);        

 end;

   res:=(n/(i-1));  

   write(out,res);  

   close(out);      

   close(en);

 end.

Там во вторую тупо добавляешь:

 max:=-100001;

 min:=100001;

if (mas[i]<0) and (mas[i] mod 2 = 0) and (mas[i]<min) then min:=mas[i];

 if (mas[i]>0) and (mas[i] mod 2 = 1) and (mas[i]>max) then max:=mas[i];  

if (max=-100001)or(min=100001) then writeln(out,'ERROR: please, rewrite yor file')

 else  

 begin

   writeln(out,min);

   writeln(out,max);  

Тоже такие же задачи решал)) лол). Ты не из 604??)))

спец Михасов
Вызов G(5)+F(5)

Вход G(5), вызов F(4)+2G(4)
Вход F(4), вызов 2F(3)-G(3)
Вход F(3), вызов 2F(2)-G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(3), вызов F(2)+2G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(4), вызов F(3)+2G(3)
Вход F(3), вызов 2F(2)-G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(3), вызов F(2)+2G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход F(5), вызов 2F(4)-G(4)
Вход F(4), вызов 2F(3)-G(3)
Вход F(3), вызов 2F(2)-G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(3), вызов F(2)+2G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(4), вызов F(3)+2G(3)
Вход F(3), вызов 2F(2)-G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(3), вызов F(2)+2G(2)
Вход F(2), вызов 2F(1)-G(1)
Вход F(1), результат 1
Вход G(1), результат 1
Вход G(2), вызов F(1)+2G(1)
Вход F(1), результат 1
Вход G(1), результат 1

-14
Semenova
1. Установим допустимые сочетания двух последних битов (битов четности).
Если в N было четное количество единиц, то дописывается ноль. Поскольку ноль не меняет количества единиц, второй бит четности тоже будет нулевым. Правило №1: Если в двоичном представлении четное количество единиц, то дописывается 00.
Если в N было нечетное количество единиц, то дописывается единица. Это меняет количество единиц на четное, поэтому второй бит четности будет нулевым. Правило №2: Если в двоичном представлении нечетное количество единиц, то дописывается 10.

Первое число R, большее 180, это 181. Переведем его в двоичную систему счисления.
181₁₀ = 10110101₂
Мы видим, что оба наших правила нарушены, т.е. число 181 не подходит в качестве R.
Представление N (101101) содержит четное количество единиц, а для четного количества действует Правило №1 и мы должны записать 00, что уменьшит наше минимально возможное число R=181₁₀
Но если мы в числе N поменяем местами два правых бита, получим число 101110, которое больше чем 101101 и теперь по все тому же Правилу №1 мы получаем право приписать два нолика и получить R=10111000₂ = 184₁₀

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ребят , сколько сможете Задание 1 Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл. Задание 2 Напишите программу, которая находит минимальное четное среди отрицательных и максимальное нечетное среди положительных чисел, записанных в файле, и выводит результат в виде написанных в столбик чисел в другой файл. Учтите, что таких чисел может вообще не быть.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Natalimis416024
Ingakazakova
ooo-krasa
el-dent12
Goldglobe
ksvish2012
modos201276
Boss5519
Елена Васильева839
nord248
iraimironova
arnika-ooo1
fakyou170
TatiyanaBe20135263
voloshin238
▲