Kalmikova1666
?>

Меня зовут Иван. Составьте программу, которая печатает в первой строке одну первую букву Вашего имени, во второй – две первые буквы, в третьей -3, ..., в строке с номером к - к первых букв. Печать строки оформить через процедуру. Число строк вводить с клавиатуры. Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию. После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран.заполнить) ');

Информатика

Ответы

Galinagol559
Если задача заключается в том, что нужно поменять местами два столбца матрицы, то в приведенном фрагменте много лишних переменных.
Программа:
Program JHK;
const n=5;
var d:array[1..n,1..n]of real; 
i,j:integer; a:real;
begin
writeln('Исходный массив:');
for i:=1 to n do
begin
 for j:=1 to n do
  begin
  d[i,j]:=sin(i+j);
  write(d[i,j]:6:2);
  end;
writeln;
end;
for i:=1 to n do
 begin a:=d[i,1]; d[i,1]:=d[i,n]; d[i,n]:=a; end;
writeln('Измененный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do write(d[i,j]:6:2);
 writeln;
 end;
end.

Результат:
Исходный массив:
  0.91  0.14 -0.76 -0.96 -0.28
  0.14 -0.76 -0.96 -0.28  0.66
 -0.76 -0.96 -0.28  0.66  0.99
 -0.96 -0.28  0.66  0.99  0.41
 -0.28  0.66  0.99  0.41 -0.54
Измененный массив:
 -0.28  0.14 -0.76 -0.96  0.91
  0.66 -0.76 -0.96 -0.28  0.14
  0.99 -0.96 -0.28  0.66 -0.76
  0.41 -0.28  0.66  0.99 -0.96
 -0.54  0.66  0.99  0.41 -0.28
webotryvclub21
Какие программы предназначены для обработки текстовой информации? называют представление информации изображённой  в виде нулей и единиц?двоичное кодированиедесятичное кодированиекомпьютерные величиныцифровая кодировкаКак выглядит число 116 в двоичном представлении:111100110011111110001110100Что такое файл?программа, хранящаяся на компьютере;минимальная единица измерения количества информации;это информация, хранящаяся в долговременной памяти как единое целое и обозначенная именемабзац текста, распечатанный на принтере.Сколько битов составляет 72 байт?72 битов576 битов9 битов8 битовОтметьте  понятие среди следующих словосочетаний:Надо починить компьютерЖесткий дискВ нашем классе есть отличникиПонятие – это форма мышления, которая отражает совокупность существенных признаков объекта или нескольких объектов.Определите вид следующего суждения: «Все собаки лают» двоичное число 11011 в десятичную систему счисления4311027Расширение txt, rtf, doc имеют:исполняемые файлыграфические файлытекстовые файлызвуковые файлы Выделите общее понятие:ОзероМоскваВолгаПушкин

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Меня зовут Иван. Составьте программу, которая печатает в первой строке одну первую букву Вашего имени, во второй – две первые буквы, в третьей -3, ..., в строке с номером к - к первых букв. Печать строки оформить через процедуру. Число строк вводить с клавиатуры. Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию. После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран.заполнить) ');
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ananyananar
rusdtver
Yurevich1344
KononovaMaiorov453
Naumenkova-Ivanov
shmanm26
andreyduborezz2913
ivanjeka87
zatoichi69
versalmoda2971
antongenfon
михаил
АртакСергеевич1723
Negutsa_Kseniya524
bugaevnicky