petrowich076813
?>

Подсчитайте в переменной s сумму чисел 7/5; 7/10; 7/20; 7/40; 7/80 и так далее до тех пор, пока сумма не превысит 18. Напишите программу на Pascal

Информатика

Ответы

Lolira64

program Hello;

var i : Integer;

   sum:real;

begin

i := 5;

sum := 7 / i;

while sum < 18 do

begin

i := i * 2;

sum := sum + 7 / i;

end;

writeln(sum);

writeln(i);

end.

Вадим
Решение на VB.NET:
        Const SIZE As Integer = 4
        Dim a, sum As Integer
        a = Console.ReadLine()
        sum = a
        Dim n(SIZE) As Integer
        For i = 1 To SIZE
            n(i) = a Mod 10
            a \= 10
        Next
        For i = 1 To SIZE
            For j = i + 1 To SIZE
                If n(i) > n(j) Then
                    Dim t As Integer
                    t = n(i)
                    n(i) = n(j)
                    n(j) = t
                ElseIf n(i) = n(j) Then
                    Console.WriteLine("Ошибка")
                    Exit Sub
                End If
            Next
        Next
        For i = 1 To SIZE
            sum += (n(i) + n(SIZE - i + 1)) * 10 ^ (i - 1)
        Next
        Console.WriteLine(sum)
        Console.ReadKey()
Сданной . условие - составьте программу которая учитывает все варианты, все цифры в четырехзначном ч
yakushkinayuliya
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество элементов массива:');
  var x:=ReadReal('Введите значение Х для заполнения массива:');
  var a:=ArrFill(n,x); a.Println
end.

Пример
Количество элементов массива: 13
Введите значение Х для заполнения массива: 2.5
2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5

begin
  var n:=ReadInteger('Количество элементов массива:');
  var x:=ReadInteger('Введите начальное значение Х для заполнения массива:');
  var a:=ArrGen(n,i->i+x); a.Println
end.

Пример
Количество элементов массива: 15
Введите начальное значение Х для заполнения массива: 8
8 9 10 11 12 13 14 15 16 17 18 19 20 21 22

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Подсчитайте в переменной s сумму чисел 7/5; 7/10; 7/20; 7/40; 7/80 и так далее до тех пор, пока сумма не превысит 18. Напишите программу на Pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

galkavik
opal19575
sergey3699
озерская_Мария1234
vs617
Стяжкин
chizhenkovd9
alfakurs
kattarina71
hachatryanlilit1983
e-s-i-k
alisabutusova
info7
postbox
Джамалутдинова Докучаев