Коробкова1437
?>

Написать программу, в которой с клавиатуры пользователь вводит количество килограмм, а компьютер вычисляет и выводит на экран полное количество тонн и оставшихся килограмм. Пример: Пользователь вводит: 3752 Компьютер выводит: 3т 752 кг

Информатика

Ответы

Нескажу25

Program lol;

Var

 x : array[1..3] of real;

 y : array[1..3] of real;

 a,b,c,p,s : real;

begin

 write('Введите координаты точки А: ');

 readln(x[1],y[1]);

 write('Введите координаты точки B: ');

 readln(x[2],y[2]);

 write('Введите координаты точки C: ');

 readln(x[3],y[3]);

 

 a := sqrt((x[1]-x[2])**2 + (y[1]-y[2])**2);

 b := sqrt((x[1]-x[3])**2 + (y[1]-y[3])**2);

 c := sqrt((x[2]-x[3])**2 + (y[2]-y[3])**2);

 p := (a + b + c) / 2;

 s := sqrt(p * (p-a) * (p-b) * (p-c));

 writeln('Площадь тр-ка S = ', s);

end.

Результат:


Паскаль!! Даны координаты вершин треугольника АВС. Найти его площадь. Данные для самопроверки резуль
rmitin

Задание 1

   Требуется выполнить прогнозирование заболеваемости бронхиальной астмой при концентрации угарного газа равной 3 мг/куб. м. методом восстановления значения, воспользовавшись квадратичной зависимостью, полученной в предыдущей работе.

   1. Построить следующую электронную таблицу:

   2. Подставить в ячейку А2 значение концентрации угарного газа, равного 3 мг/куб. м. В результате получим:

   Справочная информация

   Число, получаемое по формуле в ячейке В2, на самом деле является дробным. Однако не имеет смысла считать число людей, даже среднее, в дробных величинах. Дробная часть удалена — в формате вывода числа указано 0 цифр после запятой.

Задание 2

   Требуется выполнить прогнозирование заболеваемости бронхиальной астмой при концентрации угарного газа равной б мг/куб. м. методом графической экстраполяции у воспользовавшись квадратичной зависимостью, полученной в предыдущей работе.

   1. Выполнить построение квадратичного тренда по алгоритму, описанному в предыдущей работе, добавив в него следующее действие:

     => на вкладке Параметры в области Прогноз в строке вперед на установить 2 единицы.

   Здесь имеются в виду единицы используемого масштаба по горизонтальной оси.

   Полученный график приведен на рисунке.

   2. Оценить приблизительно на полученном графике значение функции при значении аргумента, равном 6.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, в которой с клавиатуры пользователь вводит количество килограмм, а компьютер вычисляет и выводит на экран полное количество тонн и оставшихся килограмм. Пример: Пользователь вводит: 3752 Компьютер выводит: 3т 752 кг
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natura-domA90
Gulyaev_Egorkina
axo-geo
veniaminsem
gbnn90
Владимирович111
Мария-Кострыгина175
tefdst
zakaz1
ekaterinkat
Валерия Воробьева396
8 сынып БЖБ 2 тоқсанс инфарматика
choia
Busyashaa
ipeshindina236
dirzhanov683