Бражинскене_Алексей
?>

Составить программу по блок-схеме и показать, используя таблицу чему будет равно значение переменной a после выполнения фрагмента алгоритма.​

Информатика

Ответы

tvshi

таблица длинная получается, надеюсь разберешься


Составить программу по блок-схеме и показать, используя таблицу чему будет равно значение переменной
Составить программу по блок-схеме и показать, используя таблицу чему будет равно значение переменной
margo929

program zz1;

var n,n1,n2,n3:integer; //задаем переменные

begin

write('введите заданное трехзначное число');

read(n); //вводим с клавиатуры заданное трехзначное число

n1:=n div 100; //находим первую цифру числа

n2:=(n mod 100) div 10; //находим вторую цифру числа

n3:=n mod 10; //находим третью цифру числа

if (n1 mod 2 = 0)and(n2 mod 2 = 0)and(n3 mod 2 = 0) //проверяем, если все цифры четные, то выводим один ответ, если нет, то другой

then write('все цифры числа четные ') else write('некоторые цифры числа не четные');

Объяснение:

fedorenkoroman
1)
Var
n,m,max,min:integer;
Begin
write('Введите число: ');
readln(n);
min:=9;   
max:=0;
while n>0 do 
begin 
m:=n mod 10; 
if m<min then min:=m; 
if m>max then max:=m; 
n:=n div 10; end;   
writeln('Максимальное число: ',max);   
writeln('Минимальное число: ',min);
End.
2)
var
i,count: integer;
n,s:string;
begin
writeln('Введите число: ');
readln(s);
writeln('Введите цифру: ');
readln(n);
for i:=1 to length(s) do
if(s[i]=n)then
count:=count+1;
writeln('Количество раз, когда встречается цифра = ',count);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу по блок-схеме и показать, используя таблицу чему будет равно значение переменной a после выполнения фрагмента алгоритма.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

eeirikh
klodialeit36
Serkova_Elena251
Газинурович
АнжелаВасильевич
oslopovavera
olgapotapova
Vladimirovna Yevtodeva
zuzman601
Manyaya
nestruev
Chopper-hinter25
rb-zakaz
N-odes-art-school410
sergeevna