Тамара_Григорьевна897
?>

1 задание. После провидения олимпиады у вас есть призеры. Составить программу, которая выбирает и выводит на экран количество лет самого младшего призера. 2 задание. Напишите общий вид условного оператора. If<условие>then<оператор1>else<оператор2> 3 задание. Напишите вид составного оператора. Begin<последовательность операторов>end 4 задание. Допишите программу в Pascal и определите значения переменной x после выполнения программы. Запишите в документ Word. a := 2; x := a+2; if x > 4 then x := x+2*a else x:= a-x; 5 задание. Допишите программу в Pascal и определите значения переменной Z после выполнения программы. Запишите в документ балов даю!

Информатика

Ответы

mbudilina

Привет, код ниже, для справки по функциям советую посетить MSDN.
Если остаются вопросы так же есть хороший сайт как METANIT, там ты можешь найти простые примеры и простую документацию.
Если хочется проверить работаю кода, то есть прекрасный ресурс как Repl It.
Если есть вопросы, пиши в комментариях. За дополнительной информацией пиши в ЛС.

за отметку "Лучшее решение" и нажатую кнопочку и у меня в профиле.
Так же в моем профиле вы можете найти полезные ссылки на ресурсы описанные выше.



using System;

class MainClass {
  public static int (int[] array)
  {
    int result = 1;
   
    foreach (int element in array)
    {
      if (0 > element)
      {
        result *= element;
      }
    }
   
    return result;
  }

  static void Main()
  {
    Console.WriteLine("Please, enter length of array: ");
    int sizeOfArray = Convert.ToInt32(Console.ReadLine());
   
    int[] array = new int[sizeOfArray];
   
    for (int i = 0; i < sizeOfArray; ++i)
    {
      Console.WriteLine("Please, enter array entry: ");
      array[i] = Convert.ToInt32(Console.ReadLine());
    }
   
    int productOfNegativeNumbers = (array);
    Console.WriteLine("Product of negative numbers is: {0}", productOfNegativeNumbers);
  }
}
pavlino-mkr

70, 35, 43, 132, 121, 11, 60, 64, 24, 31

Объяснение:

1) Изначально s = 0, затем на каждой из 12 – 6 + 1 = 7 итераций к ней прибавляется 10, итого получится 70

2) Аналогично, s = 0 + 7 * (8 – 3) = 35

3) Итерация с i = 1: k = 2 * 4 + 1 = 9. Итерация с i = 2: k = 2 * 9 + 2 = 20. Итерация с i = 3: k = 2 * 20 + 3 = 43.

4) s = 0 + 12 * 11 = 132  

5) s = 0 + 11 * (12 – 1) = 121

6) u = 26 – 1 – 2 – 3 – 4 – 5 = 11

7) s = 4 + 5 + … + 11 = 60

8) s = 1 * 2 * 2 * … * 2 (8 – 3 + 1 раз) = 64

9) y = 0 + 4 * 1 + 4 * 2 + 4 * 3 = 24

10) s = 3 + 2 * 2 + 2 * 3 + 2 * 4 + 2 * 5 = 31

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1 задание. После провидения олимпиады у вас есть призеры. Составить программу, которая выбирает и выводит на экран количество лет самого младшего призера. 2 задание. Напишите общий вид условного оператора. If<условие>then<оператор1>else<оператор2> 3 задание. Напишите вид составного оператора. Begin<последовательность операторов>end 4 задание. Допишите программу в Pascal и определите значения переменной x после выполнения программы. Запишите в документ Word. a := 2; x := a+2; if x > 4 then x := x+2*a else x:= a-x; 5 задание. Допишите программу в Pascal и определите значения переменной Z после выполнения программы. Запишите в документ балов даю!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

innaterenina
vetviptime
lighturist
kulibabad566
Arsen-araqelyan20164
Elizavetaborisovna1992
kseniyavaganova
Gennadievna bessonov
gresovanatalya
Nugamanova-Tatyana840
alexeylipatov
dima8585
Yurkov
Sacharov84
zvanton