Aleksandrovich1075
?>

Составить программу вычисления суммы элементов массива а [1..5], который заполняется с клавиатуры целыми числами. Нужно описать массив в разделе описания переменных, не забыть описать также и другие переменные, которые будете использовать. Затем нужно вывести сообщение, чтобы пользователь ввел элементы массива, затем вставить фрагмент для заполнения массива данными с клавиатуры Затем вставит фрагмент вычисления суммы элементов массива Затем вывести значение суммы.

Информатика

Ответы

asyaurkova

Текст программы:

var a:array[1..5] of integer;

i, sum:integer;

begin

 writeln('Введите числа');

 for i:=1 to 5 do

   readln(a[i]);

 sum:= 0;

 for i:=1 to 5 do

   sum:= sum + a[i];

 writeln('Сумма = ', sum);

end.

rukodelnizza1

Задача 1)

var a: real;

begin

 writeln('Вычислите выражение 12*6 - 13*3');

 readln(a);

 if a=33 then writeln('Правильно') else writeln('Ошибка в расчётах');

end.

Задача 2)

var a: real;

begin

 writeln('Сколько вам лет?');

 readln(a);

 if a<14 then writeln('Вы ещё не получили паспорт!') else writeln('Паспорт вами получен!');

end.

Задача 3)

program pocupka;

var a: string;

begin

 writeln('Какое мороженное вы хотите купить эскимо, фруктовый лёд или пломбир?');

 readln(a);

 if a='эскимо' then writeln('50 рублей');

 if a='фруктовый лёд' then writeln('30 рублей');

 if a='пломбир' then writeln('48 рублей');

end.

Объяснение:

Zaikinarusina

using System;

using System.Linq;  //Оно не может в многомерные массивы :(

namespace CSLearn

{

   class Program

   {

       static void Main(string[] args)

       {

           //Объявляем всякое

           Random random = new Random();

           const int n = 5;

           const int m = 10;

           int counter = 0;

           int[,] myarray = new int[n, m];

           //Забьём наш массив рандомными элементами

           for (int row = 0; row < n; row++)

           {

               for (int pos = 0; pos < m; pos++)

               {

                   myarray[row, pos] = random.Next(-99, 99);

               }

           }

         

           //Пробежимся по всему нашему массиву, и посчитаем кол-во элементов, удовлетворяющих условиям.  

           foreach (int item in myarray)

           {

               if (item > -9 && item < 0) counter++;

           }

           Console.WriteLine(counter);

           Console.ReadKey();

       }

   }

}

p.s Осторожно, код написан питонистом :D

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления суммы элементов массива а [1..5], который заполняется с клавиатуры целыми числами. Нужно описать массив в разделе описания переменных, не забыть описать также и другие переменные, которые будете использовать. Затем нужно вывести сообщение, чтобы пользователь ввел элементы массива, затем вставить фрагмент для заполнения массива данными с клавиатуры Затем вставит фрагмент вычисления суммы элементов массива Затем вывести значение суммы.
Ваше имя (никнейм)*
Email*
Комментарий*