MikhailovichKrizhnaya578
?>

Составьте программу для решения задачи на языке Pascal: 1. Найти значение функции а=. Обратите внимание, что выражение записано под знаком корня, значит должно выполняться определенное условие. Значения переменных ввести с клавиатуры. 2. Ввести две переменные и найти разность большей и меньшей из них. Рассмотреть оба случая, т. е. большей может быть и одна и другая переменная. Переменные нужно сравнить и выполнить вычисления, когда одна из них больше, иначе – вторая будет больше. Ввести также дополнительную переменную, которая будет обозначать результат вычисления.

Информатика

Ответы

sodrugestvo48

Задача 1:

program P1;

var a,b: real;

begin

write('b = '); readln(b);

if 32 - b < 0 then writeln('error') else begin

a := sqrt(32 - b);

writeln(a:0:4);

end;

end.

Задача 2:

program P2;

var a,b,result: real;

begin

write('a = '); readln(a);

write('b = '); readln(b);

if a > b then result := a - b else result := b - a;

writeln(result:0:4);

end.

petrowich076813

Информационная ёмкость всемирной сети Интернет просто огромна! Каждая сфера деятельности, любые вопросы, волнующие человека, находят своё отражение на множестве сайтов. Не является здесь исключением и здравоохранение. В Сети можно найти материалы, представляющие интерес для пациентов, практикующих врачей, организаторов здравоохранения, научных работников, страховых компаний, коммерсантов… Существуют специфические ресурсы, интересные каждой отдельной группе, но есть и такие, которые необходимы многим.

Однако польза от интернет-ресурсов зависит от того, насколько хорошо мы их знаем. Поэтому для облегчения восприятия лучше начать с их классификации.

Итак, медицинские ресурсы (сайты или отдельные странички) сети Интернет можно разделить по типу посетителей и по цели посещения. А поскольку один сайт может предоставлять посетителям информацию разного назначения (как, например, порталы), то классифицировать мы будем не сайты целиком, а отдельные тематические группы информации (тематические ресурсы). Описанную в статье коллекцию ссылок можно найти на сайте www.it2med.ru.

По типу ожидаемых посетителей (“целевая аудитория”) можно выделить следующие группы ресурсов.

Группа А — для пациентов (ресурсы, предлагающие справочную медицинскую информацию о различных заболеваниях, их симптомах профилактики или простого “домашнего” лечения, о врачах и учреждениях, оказывающих соответствующую медицинскую

Группа Б — для специалистов лечебно-диагностических подразделений (специализированная медицинская информация для специалистов практического здравоохранения и научных работников, которая может быть им полезна при проведении профилактических, лечебно-диагностических или реабилитационных мероприятий).

Группа В — для специалистов по организации здравоохранения (законодательные и нормативные акты, справочные материалы, полезные для организации работы и подготовки отчетности учреждений и отдельных частнопрактикующих врачей, а также аутсорсинговые ресурсы — медицинские услуги, оказываемые другими учреждениями и коммерческими фирмами по договорам).

Группа Д — для специалистов финансово-хозяйственных служб и коммерсантов (здесь предлагается продукция, необходимая для обеспечения деятельности медицинских учреждений, — оборудование, медикаменты, расходные материалы, инструментарий, средства связи, транспорт и т. д.).

Группа Е — для специалистов кадровых служб и поиска работы (ресурсы, предлагающие вакансии учреждений и резюме специалистов).

misterdre9991

Цикл с параметром был уже рассмотрен нами в разделе "Алгоритм" в теме "Виды алгоритмов".

       Цикл с параметром используется,  когда заранее известно сколько раз должен выполниться цикл.  

Формат записи цикла:  

For  <пар.цикла> := <нач.знач> to <кон.знач.> do <оператор>

       Здесь for, to, do - зарезервированные слова (для, до, выполнить);  

<пар. цикла> - параметр цикла – переменная целочисленного типа (типа integer);  

<нач. знач.> - начальное значение - число или переменная целочисленного типа (типа integer);  

<кон. знач.> - конечное значение - число или переменная целочисленного типа (типа integer);  

<оператор> - произвольный оператор Паскаля.  

Пример:  For i:=1 to n do <оператор>

здесь i - параметр цикла

        1 - начальное значение

        n - конечное значение        

       Если в теле цикла используется несколько операторов, тогда, используются операторные скобки: begin ... end.  

       При выполнении оператора for вначале вычисляется выражение <нач .знач.> и осуществляется присваивание его значения переменной цикла <пар .цикла> := <нач. знач.>. Далее сравниваются <пар .цикла> и  <кон.знач.>. До тех пор, пока они не станут равными будет выполняться оператор (операторы). Значение переменной цикла <нач.знач> автоматически увеличивается на единицу в ходе выполнения цикла. Надо сразу заметить, что задать шаг цикла, отличный от 1 в этом операторе нельзя.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для решения задачи на языке Pascal: 1. Найти значение функции а=. Обратите внимание, что выражение записано под знаком корня, значит должно выполняться определенное условие. Значения переменных ввести с клавиатуры. 2. Ввести две переменные и найти разность большей и меньшей из них. Рассмотреть оба случая, т. е. большей может быть и одна и другая переменная. Переменные нужно сравнить и выполнить вычисления, когда одна из них больше, иначе – вторая будет больше. Ввести также дополнительную переменную, которая будет обозначать результат вычисления.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dmdlir
kiparistop
ainred
Александр Сергей
punctvydachi
elenachuxina804
Чубкова1290
Абумислимовна_кооператив585
Какой вопрос имеет блоку умовы​
mrFuz
beaevgen711
Dmitrievich1871
lobutev
Дмитрий-Олейникова
dianabuchkina
ddavydov1116
▲