ivanovanata36937365
?>

Напишите программу: В каждой строке файла записано три числа, каждое из которых находится в интервале [0, 255]. Эти числа обозначают красную, зелёную и синюю составляющие цвета в цветовой модели RGB. Запишите в другой файл полные коды заданных цветов в виде целых чисел (код цвета = 255·255·R + 255·G + B

Информатика

Ответы

kapi30
Function ST(a,b,c:real):real;
var
  p:real;
begin
  p:=(a+b+c)/2;
  ST:=sqrt(p*(p-a)*(p-b)*(p-c))
end;

var
  a,s:array[1..3] of real;
  i,k:integer;
begin
  Write('Введите длину стороны каждого треугольника: ');
  for i:=1 to 3 do begin
    Read(a[i]);
    s[i]:=ST(a[i],a[i],a[i]);
    end;
  if s[1]>s[2] then k:=1 else k:=2;
  if s[3]>s[k] then k:=3;
  Writeln('Треугольник номер ',k,' имеет наибольшую площадь')
end.

Пример
Введите длину стороны каждого треугольника: 6 7.3 4.18
Треугольник номер 2 имеет наибольшую площадь
Леонтьева

задача2

посчитаем общее количество шариков в мешочке по формуле N=2^i

подставим в эту формулу 3 и получим двойку в третьей степени - это 8 шариков

задача3

общее количество вариантов рассчитывается по формуле  по формуле N=2^i подставим в эту формулу 16 и получим двойку в четвертой  степени т.е. i=4 бита

задача5

запишем условие: I=450 бит, К=150, i=?

решение: найдем вес одного символа , разделим I на K - получим

i=450/150=3 бита

задача9

запишем условие: I=2Кб, К=8192, N=?

решение: выразим объем информационного сообщения в битах

I=2*1024*8=16384 бит  найдем вес одного символа , разделим I на K - получим

i=16384/8192=2 бита если i=2  если вес одного символа 2, то мощность алфавита равна 4

 задача11

определим, сколько символов в алфавите планеты Альфа. Для этого вычеркнем из сообщения повторяющиеся символы: букву М, К, Н, О

осталось вот что: МКЛНОПРСТ! - всего 10 символов

определим вес 1 символа по таблице нецелых степеней числа 2: i=3.32 бита. В исходном тексте 15 символов, поэтому умножим наше i на 15

I=15*3.32=49.8 бит



Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу: В каждой строке файла записано три числа, каждое из которых находится в интервале [0, 255]. Эти числа обозначают красную, зелёную и синюю составляющие цвета в цветовой модели RGB. Запишите в другой файл полные коды заданных цветов в виде целых чисел (код цвета = 255·255·R + 255·G + B
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ulechkaevseeva
Aleksandrovna370
Aliferenko
vbnm100584
a800000
syana80
snabdonm501
Мусаев Игоревич371
isaev
evsmorodina
innaterenina
dfyurst708
Vipnikavto58
Delyaginmikhail
Татьяна Марина1287