fta1309
?>

ОЧЕНЬ-ОЧЕНЬ ОЧЕНЬ-ОЧЕНЬ напишите программу которая будет запрашивать ввод числа и вывод числа с клавиатуры считает квадрат и даёт результат​

Информатика

Ответы

Поликарпова-Мазурова

Объяснение:

Во вложении


ОЧЕНЬ-ОЧЕНЬ ОЧЕНЬ-ОЧЕНЬ напишите программу которая будет запрашивать ввод числа и вывод числа с клав
Екатерина

uses crt;

var n,m,i,p:longint;

   s,k:byte;

begin

clrscr;

repeat

write('Введите натуральное число N=');

readln(n);

until n>0;

m:=n;

s:=0;

while m>0 do

begin

 s:=s+m mod 10;

 m:=m div 10;

end;

writeln('Числа от 1 до ',n-1,', у которых произведение цифр=',s);

k:=0;

for i:=1 to n-1 do

begin

 m:=i;

 p:=1;

 while m>0 do

  begin

   p:=p*(m mod 10);

   m:=m div 10;

  end;

 if p=s then

  begin

   k:=1;

   write(i,' ');

  end;

end;

if k=0 then write('Таких чисел нет');

readln

end.

Объяснение:

nairahay

#include "stdafx.h"

#include "iostream"

using namespace std;

int _tmain(int argc, _TCHAR* argv[])

{

setlocale(LC_ALL, "Russian");

const int SIZE = 10;

double arr[SIZE];

cout << "Введите " << SIZE << " чисел:" << endl;

for (int i=0; i<SIZE; i++)

cin >> arr[i];

int index = -1;

for (int i=SIZE-1; i>=0; i--)

if (arr[i] < 0)

{

index = i;

break;

}

if (index != -1)

{

int sum = 0;

for (int i=index+1; i<SIZE; i++)

sum = sum + arr[i];

cout << "Сумма " << sum << endl;

}

else

cout << "В массиве нет отрицательных элементов" << endl;

system("pause");

return 0;

}

3:

#include <iostream>

#include <cstdlib>

using namespace std;

#define n 10

int main(){

int mas[n], max = -9999;

cout<<"Before :";

for(int i = 0; i < n; i++){

mas[i] = rand()% 50 + 1;

cout<<mas[i]<<" ";

if(mas[i] > max)

max = mas[i];

}

double tmp = max - (max * 0.2);

cout<<endl<<"Max = "<<max<<" tmp = "<<tmp<<endl<<"After: ";

for(int i = 0; i < n; i++)

if(mas[i] >= tmp)

cout<<mas[i]<<" ";

for(int i = 0; i < n; i++)

if(!(mas[i] >= tmp))

cout<<mas[i]<<" ";

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ОЧЕНЬ-ОЧЕНЬ ОЧЕНЬ-ОЧЕНЬ напишите программу которая будет запрашивать ввод числа и вывод числа с клавиатуры считает квадрат и даёт результат​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

КристинаАлександр
Valerevna Tuzova
avto3132
bal4shovser16
akarabut343
Кожуховский398
adminaa
d43irina
fixer2006
gernovoy
aa276568
denspiel
dzo-dzo
shajmasha
kamalfayed229