Liliya_Ivanova
?>

Составить программу перевода заданного натурального числа N в систему счисления с основанием X. Использовать в программе вс алгоритм «процедура» для перевода из десятичной системы счисления в любую другую. Дополнительные условия: 1. Основная программа должна содержать ввод двух переменных (N и X – это глобальные параметры) и обращение к процедуре. 2. Имя процедуры любое на усмотрение разработчика программы. 3. Процедура должна оперировать с двумя входными данными (это локальные параметры), содержать основной алгоритм вычислений и вывод результата. Задача №2 Составить программу вычисления площади четырехугольника произвольной формы с длинами сторон A, B, C, D и диагональю F. Использовать в программе вс алгоритм «функция» для вычисления площади одного треугольника. Дополнительные условия: 1. Основная программа должна содержать ввод пяти переменных (A, B, C, D, F – глобальные параметры), обращение к функции (2 раза), вычисление общей площади четырехугольника и вывод результата. 2. Имя функции любое на усмотрение разработчика программы. 3. Функция должна оперировать с тремя входными данными (это локальные параметры) и содержать основной алгоритм вычисления площади треугольника по формуле Герона

Информатика

Ответы

ekaterinkat

Локальная сеть - понятие

Сеть - группа компьютеров, соединенных друг с другом, с оборудования, кабелей, wi fi или иным обеспечивающего пакетный обмен информацией между ними. Вся информация в сети передается пакетным образом с ипользованием протоколов IP и TCP. Сегодня обмен между компьютерами осуществляется именно таким образом и другие мы не будем рассматривать подробно по причине их редкого использования. Соединение между двумя компьютерами может быть непосредственным или с использованием локальной сети управляемой роутером

viz-art-pnz1664

#include <iostream>

using namespace std;

int main()

{

   int array[18][12] = {};

   for (int i = 0; i < 18; i++)

   {

       for (int j = 0; j < 12; j++)

       {

           cin >> array[i][j];

       }

       cout << endl;

   }

   int sum = 0;

   for (int i = 0; i < 18; i++)

   {

       int j = 5;

       sum += array[i][j];

   }

   cout << sum;

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

using namespace std;  // Пространство имён

int main()

{

   int array[18][12] = {};  // Обнуляем двумерный массив

// Ввод массива

   for (int i = 0; i < 18; i++)

   {

       for (int j = 0; j < 12; j++)

       {

           cin >> array[i][j];  // Ввод элемента в i строку и j столбец

       }

       cout << endl;  // Перенос на следующую строку

   }

// Сумма 6 столбца ( июня )

   int sum = 0;  // Переменная, которая будет хранить в себе сумму

   for (int i = 0; i < 18; i++)

   {

       int j = 5;  // Индексация начинается с нуля ⇒ 6 (июнь) столбец = 5 индексу

       sum += array[i][j];  // Сумма i элемента 5 столбца

   }

   cout << sum;  // Вывод суммы

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу перевода заданного натурального числа N в систему счисления с основанием X. Использовать в программе вс алгоритм «процедура» для перевода из десятичной системы счисления в любую другую. Дополнительные условия: 1. Основная программа должна содержать ввод двух переменных (N и X – это глобальные параметры) и обращение к процедуре. 2. Имя процедуры любое на усмотрение разработчика программы. 3. Процедура должна оперировать с двумя входными данными (это локальные параметры), содержать основной алгоритм вычислений и вывод результата. Задача №2 Составить программу вычисления площади четырехугольника произвольной формы с длинами сторон A, B, C, D и диагональю F. Использовать в программе вс алгоритм «функция» для вычисления площади одного треугольника. Дополнительные условия: 1. Основная программа должна содержать ввод пяти переменных (A, B, C, D, F – глобальные параметры), обращение к функции (2 раза), вычисление общей площади четырехугольника и вывод результата. 2. Имя функции любое на усмотрение разработчика программы. 3. Функция должна оперировать с тремя входными данными (это локальные параметры) и содержать основной алгоритм вычисления площади треугольника по формуле Герона
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Грачева мураховская
polikarpov-70
AnnaChulyukanova3
ksen1280
Dato24043846
kuharchuks
P7Y7V7
Аношкина1696
POMILEVAVladimirovna269
snabdonm501
igor-790
Качкова1820
jgaishun756
Ruslan374
НосовЖелиховская
▲