abakas235
?>

Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом – цикл с переменнойна языке питон)

Информатика

Ответы

bespalovaannaanna

# цикл с условием

n = int(input())

i = 0

sum_nums = 0

while i < n:

   i += 1

   sum_nums += i

print(sum_nums)

# цикл с переменной

n = int(input())

sum_nums = 0

for i in range(n + 1):

   sum_nums += i

print(sum_nums)

Объяснение:

pnat1235

Управление памятью – одна из главных задач ОС. Она критична как для программирования, так и для системного администрирования.

Объяснение:

Каждый процесс в многозадачной ОС работает в своей «песочнице» в памяти. Это виртуальное адресное пространство, которое в 32-битном режиме представляет собою 4Гб блок адресов. Эти виртуальные адреса ставятся в соответствие (mapping) физической памяти таблицами страниц, которые поддерживает ядро ОС. У каждого процесса есть свой набор таблиц. Но если мы начинаем использовать виртуальную адресацию, приходится использовать её для всех программ, работающих на компьютере – включая и само ядро.

Роман_Гречина
5) Проверим предлагаемые варианты ответов.
- Г = 1: Явно однозначности нет: 101 можно расшифровать как В или ГАГ.
Итак, одним битом букву Г закодировать нельзя, попробуем двумя.
- Г = 11: можно! Получится префиксный код (потому расшифровка будет однозначной).
- Г = 01. Однозначности нет: 0101 расшифровывается как ГГ или АВ.
Дальше проверять бессмысленно: 010 состоит из 3 битов.
ответ. 2) 11.

7) Опять проверяем.
- Г = 11. Нет однозначности: 11 может быть расшифровано как ББ или Г.
- Г = 000: подходит, т.к. получается префиксный код.
Остальные варианты не короче этого.
ответ. 2) 000.



Для справки. Префиксным кодом называется такой кодировки, при котором код никакого символа не начинается кодом другого символа (т.е. если, например, код символа 'a' есть 01001, то все остальные коды символов не могут начинаться на 01001...). Еще бывают постфиксные коды (когда коды не могут оканчиваться кодами других символов). Префиксные и постфиксные коды можно расшифровать однозначно (однако бывают коды, не являющиеся постфиксными или префиксными, но при этом допускающие однозначную расшифровку)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом – цикл с переменнойна языке питон)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rukodelnizza1
Штакина1568
Dmitrychekov9
zodgener
kotovayaanastasia2069
annino
vsbrelok
ГалинаРайгородская
maximovpavel9114
martabunova
macmakka
janepustu
Дмитрий_Евлампиев518
Стародубцева_Васильевич485
gavrilasmax05