marketing
?>

Заданы переменные a=12; b=5. Каковы будут значения этих переменных после выполнения следующего фрагмента программы: a) a:=b; b:=a; c:=a+b; b) f:=y; y:=x; x:=f; c:=a+b. Составить программу, используя оператор while (Паскаль

Информатика

Ответы

festjob
1.
var
x:integer;
y:real;
begin
write('Введите значение аргумента "X" : ');
readln(x);
y:=3*cos((5*x));
writeln('Значение функции "Y" = ',y);
readln;
end.

2.
var
x,b:integer;
begin
write('Введите количество молока, полученного за день, л : ');
readln(x);
write('Введите количество дней : ');
readln(b);
writeln('Количество молока, полученного за заданный промежуток времени = ',x*b);
readln;
end.  

3.
var
a,b,c:integer;
begin
write('Введите двузначное число: ');
readln(a);
b:=a div 10;
c:=a mod 10;
writeln(b,#10,c);
end.

4.
var
b:integer;
a:longint;
begin
write('Введите целое число: ');
readln(a);
  b:=a div 100 mod 100;
writeln(b);
readln;
end.

5. 
var
a,b:integer;
begin
write('Введите числа : ');
readln(a,b);
if a and b mod 2=0 then
 writeln(a+b);
if a and b mod 2<>0 then
 writeln(a*b);
readln;
end.
{Про последнее "Иначе", увеличьте все числа в пять раз и выведите результаты" не очень понялЕсли оба чётные - сумма, если оба - нечётные - то произведение. А если иначе, то число должно быть равно нулю. Смысл увеличивать его в пять раз?)}
Volochaev
1.
var
x:integer;
y:real;
begin
write('Введите значение аргумента "X" : ');
readln(x);
y:=3*cos((5*x));
writeln('Значение функции "Y" = ',y);
readln;
end.

2.
var
x,b:integer;
begin
write('Введите количество молока, полученного за день, л : ');
readln(x);
write('Введите количество дней : ');
readln(b);
writeln('Количество молока, полученного за заданный промежуток времени = ',x*b);
readln;
end.  

3.
var
a,b,c:integer;
begin
write('Введите двузначное число: ');
readln(a);
b:=a div 10;
c:=a mod 10;
writeln(b,#10,c);
end.

4.
var
b:integer;
a:longint;
begin
write('Введите целое число: ');
readln(a);
  b:=a div 100 mod 100;
writeln(b);
readln;
end.

5. 
var
a,b:integer;
begin
write('Введите числа : ');
readln(a,b);
if a and b mod 2=0 then
 writeln(a+b);
if a and b mod 2<>0 then
 writeln(a*b);
readln;
end.
{Про последнее "Иначе", увеличьте все числа в пять раз и выведите результаты" не очень понялЕсли оба чётные - сумма, если оба - нечётные - то произведение. А если иначе, то число должно быть равно нулю. Смысл увеличивать его в пять раз?)}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заданы переменные a=12; b=5. Каковы будут значения этих переменных после выполнения следующего фрагмента программы: a) a:=b; b:=a; c:=a+b; b) f:=y; y:=x; x:=f; c:=a+b. Составить программу, используя оператор while (Паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Oksana-Kirakosyan1301
gorsimonyan4
optikmir
AleksandrIvanovich1273
Viktor1316
tarasovs
ranocchio6
peregovorkacoffee
minchevaelena23
punchf
Mikhailovna1444
kotikdmytriy11
lider123
morsh9345
afilippov3321