testovvanya
?>

информатика : Написать программы в тетрадях. Задача № 1: Ввести число. Если оно неотрицательно, прибавить к нему 30, в противном случае вычесть 20. Задача №2 Ввести рост человека. Вывести на экран "выше среднего", если его рост превышает, 170 см и "ниже среднего" если ниже 170см. Задача № 3 Фирма осуществляет набор сотрудников. Условия приема требуют не менее 2 лет рабочего стажа и возраст более 30 лет. Написать программу, проверяющую, удовлетворяет ли кандидат этим требованиям

Информатика

Ответы

Yevgeniya Bessonov

using System;

namespace kp9p_pr_10_zad_6

{

   class Program

   {

       delegate void Square(double a1, double b1, double alfa1);

       static void Main(string[] args)

       {

           double a, b; // переменные для сторон a и b  

           double alpha; // переменная для угла альфа  

           Console.WriteLine("Введите значения треугольника:\n ");

           Console.Write("a: ");

           a = double.Parse(Console.ReadLine());   // ввод стороны a  

           Console.Write("b: ");

           b = double.Parse(Console.ReadLine()); // ввод стороны b  

           Console.Write("Угол альфа: ");

           alpha = double.Parse(Console.ReadLine()); // ввод угла альфа  

           sq(a, b, alpha);  

           static void sq(double a1, double b1, double alpha1) // функция sq расчета и вывода площади  

           {

               Console.WriteLine("\nПлощадь: {0}", (a1 * b1 * Math.Sin(alpha1)) / 2); // вывод и расчет площади  

           }

       }

   }

}  

fitzhu
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№6

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99).Println;
  Writeln('[',a.Min,';',a.Max,']')
end.

Пример
n= 13
72 -77 -88 -99 -2 -61 67 40 -30 -28 91 -56 29
[-99;91]

№9

begin
  var a:=ReadArrReal('Вводите:',ReadInteger('n='));
  Writeln('Положительных: ',a.Where(t->t>0).Count);
  Writeln('Отрицательных: ',a.Where(t->t<0).Count);
  Writeln('Нулевых: ',a.Where(t->t=0).Count)
end.

Пример
n= 10
Вводите: 3.7 12.6 -4 0 -13.2 0.7 0 14 2.12 0.004
Положительных: 6
Отрицательных: 2
Нулевых: 2

№16

begin
  var a:=Arr(-3.7,-3.1,-2.3,-1.6,-0.9,-0.2,0.5,1.2,1.9,2.6,3.3,4.0,4.2,5.4,
      1.92,1.76,1.52,1.26,0.95,0.45,0.71,1.10,1.38,1.61,1.82,2.00,2.05,2.32);
  var d:=a.Length div 2;
  for var i:=0 to d-1 do Writeln(a[i]:5:2,a[i+d]:20:3)
end.

Результат
-3.70               1.920
-3.10               1.760
-2.30               1.520
-1.60               1.260
-0.90               0.950
-0.20               0.450
 0.50               0.710
 1.20               1.100
 1.90               1.380
 2.60               1.610
 3.30               1.820
 4.00               2.000
 4.20               2.050
 5.40               2.320

№19

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var i:=1;
  while i<=n do begin
    Print(a[i-1]);
    i*=2
    end;
  Writeln
end.

Пример
n= 17
-43 -41 -37 -43 12 45 -34 -19 -38 33 -34 39 -40 33 -46 4 39
-43 -41 -43 -19 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

информатика : Написать программы в тетрадях. Задача № 1: Ввести число. Если оно неотрицательно, прибавить к нему 30, в противном случае вычесть 20. Задача №2 Ввести рост человека. Вывести на экран "выше среднего", если его рост превышает, 170 см и "ниже среднего" если ниже 170см. Задача № 3 Фирма осуществляет набор сотрудников. Условия приема требуют не менее 2 лет рабочего стажа и возраст более 30 лет. Написать программу, проверяющую, удовлетворяет ли кандидат этим требованиям
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ЛаринаЛощаков
merzlikinairena
morozmd
fafina12586
evageniy79
libirishka7910
sdvigov
Yurii537
Пронкина_TEST1682
MaratФам
agaltsova86
Umkatoys50
shchepinasm
andrew409
modno-trikotazh
▲