Поделитесь своими знаниями, ответьте на вопрос:
Дан массив из 10 целых чисел заполненный случайными числами из интервала [5; 21]. 1.Выведите этот массив в строку и найдите сумму четных, положительных элементов массива, которые больше 5. 2.Найдите минимальный элемент в массиве. 3.Выполнить сортировку массива по убыванию.
var a:array[1..4, 1..5] of integer;
i,j,k:integer;
begin
writeln('Заполните матрицу');
for i:=1 to 4 do
for j:=1 to 5 do begin
read(a[i,j]);
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j];
end;
writeln('Сумма элементов кратных 3-м и > 20 = ',k);
end.
Задача №2
var a:array[1..5, 1..5] of integer;
i,j,k:integer;
begin
writeln('Заполните матрицу');
for i:=1 to 5 do
for j:=1 to 5 do begin
read(a[i,j]);
if i=j then k:=k+a[i,j];
end;
writeln('Сумма элементов главной диагонали = ',k);
end.