director3
?>

Напишите программу которая запрашивает длину и ширину прямоугольника, вычисляет его площадь и длинну диагонали, а также рисует этот прямоугольник с диагональю

Информатика

Ответы

Ivanova.i.bkrasheninnikov
Во-первых, чтобы на странице появилась картинка, она и файл(с расширением .html) должны находиться в одной папке(одном каталоге), например, они находятся на рабочем столе,(кстати, проверьте расширение фотографии, она в программе имеет расширение .gif Если не будет совпадения, она не появиться, даже если в одном каталоге)
Про цвета текста. Фразы заключаем в теге
 <font color="цвет по английски"> текст </font>
Например,Профессиональные интересы  выделим красным(по-англ. red) цветом
Перед фразой Профессиональные интересы  вписываем <font color="red">
После этой фразы вписываем (закрываем тег font) </font>
Можете попробовать с другими цветами вместо 
buff-studio
Type
  mas=array[,] of integer;
var
  i,j,ik,jk,k,max:integer;
  a:mas;
  b:array[0..5]of integer;//вс массив
begin
setlength(a,5,6);
writeln('Массив:');
// в массиве b минимальное число строки
for i:=0 to 4 do
  begin
  for j:=0 to 5 do
    begin
    a[i,j]:=random(-10,10);
    write(a[i,j]:4);
    if j=0 then b[i]:=a[i,0];
    if a[i,j]<b[i] then b[i]:=a[i,j];
    end;
  writeln;
  end;
writeln('Замена минимального противоположным:');
for i:=0 to 4 do
  begin
  for j:=0 to 5 do
    begin
    if a[i,j]=b[i] then a[i,j]:=-a[i,j];
    write(a[i,j]:4);
    end;
  writeln;
  end;  
writeln('Вставка столбцов:');
// в массиве b признак наличия в столбце максимума
for i:=0 to 5 do b[i]:=0;
for i:=0 to 4 do
  for j:=1 to 5 do
    if a[i,j]>max then  max:=a[i,j];
for i:=0 to 4 do
  for j:=0 to 5 do
    if a[i,j]=max then b[j]:=1;
for i:=0 to 5 do k:=k+b[i];
k:=5+k;
setlength(a,5,k+1);
jk:=k;
for j:=5 downto 0 do
  begin
    if b[j]=1 then
      begin
      for ik:=0 to 4 do a[ik,jk]:=1;
      jk:=jk-1;
      end;
    for ik:=0 to 4 do a[ik,jk]:=a[ik,j];
    jk:=jk-1;
  end;
for i:=0 to 4 do
  begin
  for j:=0 to k do  write(a[i,j]:4);
  writeln;
  end;  
writeln('Удаление первой строки:');
for i:=0 to 3 do
  for j:=0 to k do
    a[i,j]:=a[i+1,j];
setlength(a,4,k+1);
for i:=0 to 3 do
  begin
  for j:=0 to k do
    write(a[i,j]:4);
  writeln;
  end;  
writeln('Обмен столбцов:');
for i:=0 to 3 do
  begin
  b[i]:=a[i,k-1];
  a[i,k-1]:=a[i,k];
  a[i,k]:=b[i];
  end;
for i:=0 to 3 do
  begin
  for j:=0 to k do  write(a[i,j]:4);
  writeln;
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая запрашивает длину и ширину прямоугольника, вычисляет его площадь и длинну диагонали, а также рисует этот прямоугольник с диагональю
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

apetrov13
Городничий_Коновалова384
Plamia7917
ebelskaia
gaina6678
olg14855767
Galina-Marat1096
manuchar-formen2
aureole6452
mposte
Попов1946
buleckovd8724
krisrespect
Любовь-Волков1205
petrosyan35