ivstigres65
?>

Напишите программу, которая определяет какое из трех чисел максимальное, и выводит на экран значение максимального числа. На трех строках написаны три разных числа. Программа должна вывести максимальное из введенных трёх чисел. ​

Информатика

Ответы

gymnazium

#Python 3  

a = int(input())

b = int(input())

c = int(input())

print(max(a, b, c))

dimari81
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
raa-0485428

Усі стикаються з синтаксичними помилками. Навіть досвідчені програмісти роблять помилки. Для новачків це лише частина навчального процесу. Однак інтерпретувати повідомлення про помилки часто легко:

Помилка розбору PHP: помилка синтаксису, несподівана '{' в index.php у рядку 20

Несподіваний символ не завжди є справжнім винуватцем. Але номер рядка дає приблизне уявлення про те, з чого почати шукати.

Завжди дивіться на контекст коду . Синтаксис помилка часто приховує в згаданих або в попередніх рядках коду . Порівняйте свій код із прикладами синтаксису з посібника.

Вирішення синтаксичних помилок

Відкрийте згаданий вихідний файл. Подивіться на згаданий рядок коду .

Для втікаючих рядків і неправильних операторів зазвичай тут ви знайдете винуватця.

Прочитайте рядок зліва направо і уявіть, що робить кожен символ.

Більш регулярно потрібно також дивитися на попередні рядки .

Зокрема, пропущені ;крапки з комою відсутні у попередніх кінцях рядка / заяві. (Принаймні зі стилістичної точки зору.)

Якщо {блоки коду }неправильно закриті або вкладені, можливо, вам доведеться ще більше дослідити вихідний код. Використовуйте належне відступ коду, щоб спростити це.

Подивіться на синтаксичну забарвлення !

Рядки та змінні та константи повинні мати різні кольори.

Оператори також +-*/.повинні бути тоніровані. Інакше вони можуть опинитися в неправильному контексті.

Якщо ви бачите, що колоритація рядків поширюється занадто далеко або занадто коротко, то ви знайшли немальований або відсутній маркер закриття "або 'рядка.

Наявність двох одноколірних знаків пунктуації поруч також може означати неприємності. Як правило, оператори одинаком , якщо це не ++, --або круглі дужки після оператора. Два рядки / ідентифікатори, що прямують один за одним, у більшості контекстів невірні.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая определяет какое из трех чисел максимальное, и выводит на экран значение максимального числа. На трех строках написаны три разных числа. Программа должна вывести максимальное из введенных трёх чисел. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovich-Aleksandrovna96
Как выйти из редактора формул?​
kurmaleeva
okunevo2010
websorokin
Olenkalebedeva4477
fursov-da
Валерия Воробьева396
Lapushkin1988
Semenova
Решетникова
Sergei1198
Смирнов-Оськина
Решите как в паскале писать
mamanger
myudanova631
Sazhina1356