Алина Ракитин1730
?>

Даны два натуральных числа А и В. Установите соответствие между словесным описанием и логическим выражением, записанным по правилам языка Pascal. Что то вроде понял по познаниям php, а что то не пойму. Проверьте и дайте правильный ответ, большое

Информатика

Ответы

Антон

from random import randint

def task_26():

    """

    26. дано число, введенное с клавиатуры.

    определите сумму квадратов нечетных цифр в числе.

    """

    def square():

        number = int(input("number: "))

        s = 0

        for x in str(number):

            if int(x) % 2 ! = 0:

                s += int(x) ** 2

        print("cума квадратов нечетных цифр в числе = {}".format(s))

    square()

def task_27():

    """

    27. найдите сумму чисел, вводимых с клавиатуры.

    количество вводимых чисел заранее неизвестно.

    окончание ввода, например, слово «стоп».

    """

    def number_sum():

        numbers_sum = 0

        while true:

            number = input("number: ")

            if number == 'стоп' or number == 'стоп':

                break

            else:

                numbers_sum += int(number)

        print('suma {}'.format(numbers_sum))

    number_sum()

def task_28():

    """

    28. задана строка из стихотворения:  

    «мой дядя самых честных правил, когда не в шутку занемог,  

    он уважать себя заставил и лучше выдумать не мог»  

    удалите из строки все слова, начинающиеся на букву «м».  

    результат вывести на экран в виде строки.  

    подсказка: вспомните про модификацию списков.

    """

    def word_deleted(line):

        line_split = line.split()

        for i in range(len(line_split) - 1):   # 0,19

            if line_split[i][0] == "м" or line_split[i][0] == "м":

                del line_split[i]

        return line_split

    lines = "мой дядя самых честных правил, когда не в шутку занемог, " \

            "он уважать себя заставил и лучше выдумать не мог"

    print(word_deleted(lines))

def task_32():

    """

    32. создайте матрицу (список из вложенных списков)  

    размера n x n (фиксируются в программе), заполненную случайными  

    целыми числами.

    """

    def new_matrix(n):

        matrix = [[randint(0, 100) for x in range(n)] for i in range(n)]

        for x in matrix:

            print(x)

    new_matrix(10)

def task_45():

    """

    45. напишите функцию, которая возвращает разность между наибольшим и  

    наименьшим значениями из списка целых случайных чисел.  

    """

    def difference():

        number_random = [randint(0, 100) for i in range(50)]

        print('разность между наибольшим и наименьшим значениями = {}'.format(

            (max(number_random) - min(number_random))

        ))

    difference()

def task_46():

    """

    46. напишите программу, которая для целочисленного списка из 1000 случайных

    элементов определяет, сколько отрицательных элементов располагается  

    между его максимальным и минимальным элементами.  

    """

    def num_random_count():

        random_numbers = [randint(-500, 500) for i in range(1000)]

        index_max = random_numbers.index(max(random_numbers))

        index_min = random_numbers.index(min(random_numbers))

        count = 0

        list_range = random_numbers[index_min: index_max + 1]

        for x in list_range:

            if int(x) < 0:

                count += 1

        print("отрицательных элементов между максимальным и "

              "минимальным элементами = {}".format(count))

    num_random_count()

def task_50():

    """

    50. дан список целых чисел. определить количество четных элементов и  

    количество элементов, оканчивающихся на цифру 5.  

    """

    def func(n):

        test_list = [randint(0, 500) for i in range(n)]

        count_num = 0

        count_five = 0

        for x in test_list:

            if x % 2 == 0:

                count_num += 1

            if x % 10 == 5:

                count_five += 1

        print("количество четных элементов {}".format(count_num))

        print("количество элементов, оканчивающихся на цифру 5.   {}".format(

            count_five))

    func(50)

def task_51():

    """

    51. задан список из целых чисел. определить процентное содержание  

    элементов, превышающих среднеарифметическое всех элементов списка

    """

    def func(n):

        test_list = [randint(0, 100) for i in range(n)]

        average = sum(test_list) / len(test_list)

        count = 0

        for x in test_list:

            if x > average:

                count += 1

        print("процентное содержание элементов, превышающих"

              " среднеарифметическое всех элементов списка = {} %".format(

            round((count / average) * 100,

    func(100)

if __name__ == "__main__":

    task_26()

    task_27()

    task_28()

    task_32()

    task_45()

    task_46()

    task_50()

    task_51()

andrey4work918

информатика-это наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений

информа́ция — сведения независимо от формы их представления.

свойства информации

1)ценность

максимально возможная польза для достижения цели

2)актуальность

соответствие текущему моменту времени

3)достоверность

истинность представлений об источнике информации

4)доступность (понятность)

способность потребителя к восприятию информации

5)объективность

отображение внешнего мира независимо от наблюдателя

6)полнота

степень подробностей представлений об объекте

процессы информации

1)передача информации

процесс перемещения данных от одного пункта (источника) к другому (приемника)

2)хранение информации

действия с целью защиты найденной информации от потери, повреждения, разрушения

3)обработка информации

совокупность целенаправленных действий с полученной информацией для получения новой информации

этапы эвм

первое поколение

элементная база эвм первого поколения (конец 40-х — середина 50-х) — электронные схемы, построенные с использованием радиоламп. пример эвм первого поколения — бэсм-1(1950г.) — содержала около 7000 радиоламп, выполняла около 8000 арифметических и логических операций в секунду. , решаемые этой машиной: эксперименты по переводу научно-технических текстов с на язык, шахматные . бэсм-1 занимала большой зал, где требовалась вентиляция, стабильные источники питания, смена ламп. примеры других эвм первого поколения: цвм стрела, минск-1, м-20 и др.

  второе поколение

основа элементной базы эвм второго поколения (сер. 50-х — 70-х гг.) — элементы (, диоды). приборы позволили резко увеличить скорость выполнения операций, и быстродействие достигло нескольких миллионов операций в секунду. в эвм второго поколения использовались зу с объемом памяти на сотни тысяч машинных слов. эвм второго поколения: бэсм-2, бэсм-3, бэсм-3м, машины серии урал, мир, наири и др.

третье поколение

третье поколение эвм связывают с использованием интегральных схем (ис) среднего уровня интеграции. на одном кристалле реализуются достаточно сложные логические функции, и из них собираются сложные узлы машин. примеры эвм третьего поколения: ibm — 360, урал-12, урал-13, урал-14. самые большие семейства машин третьего поколения — это ес эвм (единой серии). быстродействие этих машин: сотни тысяч операций в секунду, объем памяти — сотни тысяч машинных слов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны два натуральных числа А и В. Установите соответствие между словесным описанием и логическим выражением, записанным по правилам языка Pascal. Что то вроде понял по познаниям php, а что то не пойму. Проверьте и дайте правильный ответ, большое
Ваше имя (никнейм)*
Email*
Комментарий*