Мелконян1137
?>

По данному псевдокоду составьте условие задачи, напишите программу и проверьте решение на компьютере. ​

Информатика

Ответы

uchpapt

Ну, если я правильно понял суть задания, то:

osh - кол-во ошибок, oc - осценка. Соль программы в том, что учитель вбивает количество ошибок, и ему выдается оценка, которую надо поставить. Что-бы программа работала, создашеь кнопку на форме, жмешь по ней два раза в VB, появится окно для ввода кода программы, туда пишешь вот эту команду:   Ocenka()

Потом после этой команды находишь строчку End Sub, она будет перед End Class, и копируешь вот этот код:

 

Sub Ocenka()
Dim osh, oc As Byte
osh = InputBox("Введите количество ошибок")
If osh = 0 Then
oc = 5
ElseIf osh = 1 Then
oc = 4
ElseIf osh = 2 Then
oc = 3
ElseIf osh >= 3 Then
oc = 2
End If
MsgBox("Оценка ученика - " & oc)
End Sub

 

Ну впринципе все) Скрин програмки прилагается)


Построение алгоритма и его реализация в среде visual basic для следующей : ученик выполнил работу. в
чухловина209

PROGRAM ThreeNumbers;

VAR

   numberOne : DOUBLE;

   numberTwo : DOUBLE;

   numberThree : DOUBLE;

   sum : DOUBLE;

   product : DOUBLE;

   average : DOUBLE;

BEGIN

   WriteLn('Введите три числа:');

   Write('Число 1 -->');

   ReadLn(numberOne);

   Write('Число 2 -->');

   ReadLn(numberTwo);

   Write('Число 3 -->');

   ReadLn(numberThree);

   sum := numberOne + numberTwo + numberThree;

   product := numberOne * numberTwo * numberThree;

   average := (numberOne + numberTwo + numberThree) / 3.0;

   WriteLn('Сумма = ', sum:6:1);

   WriteLn('Произведение = ', product:6:1);

   WriteLn('Среднее = ', average:6:1);

END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По данному псевдокоду составьте условие задачи, напишите программу и проверьте решение на компьютере. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yuliya1693
Levinalx4938
VladimirovichKazakova1202
gbfedak220
Некрасова-И
archala
sarycheva659
zakup-r51
Corneewan
pucha5261
Альберт Луиза1595
delfinmos
tolyan791
ivanovmk1977
Batishcheva